Error: Couldn't open the device file /dev/nvidiactl (No such file or directory)

Hi all,

    I am running CUDA on a Gefore 9400 GT on a Ubuntu 9.04 box. I have been able to run programs on it fairly regularly for the past 4 months without any issues. I suddenly got this error yesterday while trying to run a program.

    I searched prev threads about this error. Half of them talk about permission being denied to the user to access that file. But I am running this as the root. So that shouldn't be a problem. Besides, the error message states clearly that the required file itself isn't found. 
    I also found threads about needing to run a certain startup script on Linux to create some files that usually get created while starting x windows. Again, I am running my program from inside X windows (my progrm doesn't take a lot of GPU time) and so that shouldnt be a problem either. I tried shutting down the Gnome display manager and restarting it several times just in case.

    I had this same error once before. But, it got resolved when I re-installed the Nvidia drivers. But this time I have tried re-installing the drivers twice already and that doesn't change anything. I am still getting the error. I am out of ideas now. Any advice that you guys can give me about this would be greatly appreciated.