Error on "import pyds": /lib/aarch64-linux-gnu/ version 'GLIBC_2.29' not found

• Hardware Platform (Jetson / GPU)
Jetson Xavier NX (
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
Whatever would be installed with JetPack 5.0.2.
• NVIDIA GPU Driver Version (valid for GPU only)
Again, whatever JetPack 5.0.2 installs.

I just started the course “Building Video AI Applications at the Edge on Jetson Nano ” on a Jetson Xavier NX device. An import statement in the course sample code, “import pyds”, is causing an error.

1. I followed the course instructions to start the container on the Xavier NX as follows:
sudo docker run --runtime nvidia -it --rm --network host -v /tmp/.X11-unix/:/tmp/.X11-unix -v /tmp/argus_socket:/tmp/argus_socket -v ~/my_apps:/dli/task/my_apps --device /dev/video0

and logged in to the jupyterLab server from my host laptop.

2. In 01-ObjDetect.ipynb, I run the cell
“# Check usage of the test1 app with the help option
!cd $PYTHON_APPS/deepstream-test1-rtsp-out
&& python3 --help”

and got the following error message:

“Traceback (most recent call last):
File “”, line 31, in
import pyds
ImportError: /lib/aarch64-linux-gnu/ version `GLIBC_2.29’ not found (required by /usr/lib/aarch64-linux-gnu/”

Given that I’m using the nVidia Docker image, I’m not sure why this library wouldn’t be found. I’m not sure if I’ve missed a step somewhere or there are just additional libraries that need installed or updated?

I am having the same error in a similar scenario. I am trying to run the “Getting Started with AI on Jetson Nano” course and as in the case above, the docker container starts fine but when I try to run the jupyter cell, it gives the error above.

I have followed step by step and I don’t have idea what is missing as this is running from the DLI container.

As the original post, I am also running on a Jetson Xavier NX device using the Jetpack 5.0.2

I would appreciate any information on this issue.


You need to build pdys bindings follow this,

I cannot run the cmake command, any reason?

dings/build# cmake … -DPYTHON_MAJOR_VERSION=3 -DPYTHON_MINOR_VERSION=8 -DPIP_PLATFORM=linux_aarch64 -DDS_PATH=/opt/nvidia/deepstream/deepstream
bash: cmake: command not found

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.

Sorry above comment, you do not need to build pyds bindings. the container have included the pyds bindings.
Can you run other c/c++ app besides python app?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.