DeepStream pyds library issue

• Hardware Platform (GPU): Nvidia RTX 3060
• DeepStream Version: Triton Inference Server docker with Triton Inference Server
• NVIDIA GPU Driver Version (valid for GPU only): 470.103.01

I want to run the DeepStream test-2 sample application

Here are the steps I followed:

Run the docker container:
sudo docker run --gpus '"'device=0'"' -it -v /opt/nvidia/deepstream/deepstream/sources/python -w /opt/nvidia/deepstream/deepstream-6.0

Install dependencies

cd /opt/nvidia/deepstream/deepstream-6.0
apt-get install python-gi-dev
export GST_LIBS="-lgstreamer-1.0 -lgobject-2.0 -lglib-2.0"
export GST_CFLAGS="-pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include"
git clone
cd gst-python
git checkout 1a8f48a
./ PYTHON=/usr/bin/python
./configure PYTHON=/usr/bin/python
make install

Cloned (git clone GitHub - NVIDIA-AI-IOT/deepstream_python_apps: DeepStream SDK Python bindings and sample applications) repo of sample python applications under this dir[/opt/nvidia/deepstream/deepstream-6.0]

I tried to run the test2 sample app using this cmd:
python3 ../../../samples/streams/sample_720p.h264 1

I got the below error:

Traceback (most recent call last):
  File "", line 31, in <module>
    import pyds
ModuleNotFoundError: No module named 'pyds'

To install pyds I am following the steps as mentioned here:

cd deepstream_python_apps/bindings/
mkdir build
cd build
cmake ..
pip3 install ./pyds-1.1.0-py3-none-linux_x86_64.whl

When I run make I am facing the below error:

[  6%] Building CXX object CMakeFiles/pyds.dir/src/pyds.cpp.o
In file included from /opt/nvidia/deepstream/deepstream-6.0/sources/deepstream_python_apps/bindings/include/bind/bindanalyticsmeta.hpp:20,
                 from /opt/nvidia/deepstream/deepstream-6.0/sources/deepstream_python_apps/bindings/src/pyds.cpp:19:
/opt/nvidia/deepstream/deepstream-6.0/sources/deepstream_python_apps/bindings/include/bind/bind_string_property_definitions.h:18:10: fatal error: pybind11/pybind11.h: No such file or directory
   18 | #include "pybind11/pybind11.h"
      |          ^~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [CMakeFiles/pyds.dir/build.make:63: CMakeFiles/pyds.dir/src/pyds.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:105: CMakeFiles/pyds.dir/all] Error 2
make: *** [Makefile:84: all] Error 2

How to resolve this issue of installing pyds?


1 Like

Sorry for the late response, will have team to do the investigation and provide suggestions soon. Thanks

You should download the wheel manually here:

and COPY it into your container. Then do the pip install.

1 Like

Did you install gst-python?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.