Error: PGFIO-F-211/OPEN/unit=13/invalid file name, I need

Dear all,

I met such an error when running a program of MM5.
(OS: Fedora 8)
In REGRID part, I produced plotfmt,

./plotfmt …/ON84:1993-03-14_00


** pregrid version number: 0.28 **

PGFIO-F-211/OPEN/unit=13/invalid file name.
File name =
In source file plotfmt.f, at line number 42

I actually have the file ON84:1993-03-14_00, and it is not an empty file.
What is the possible problem?
Thank you.


Did you try with older OS such as SUSE 9 or so? I have not tried this test on Fedora 8 yet but I know that sometimes newer OS add/replace some characters to the file name such as -. This happens when I mount CD with volume name with -.

What about the file permission? It is readable?


Thank you , Hongyon
I have the permission to access the file.
I think it is the problem of the OS.
So, what is the reason ? What does this error mean?

Thank you.


How do you create plotfmt binary? What source code? I downloaded regrid source and it creates only regridder and pregridder.

Anyhow, I just look at the error, your file name is empty string? Please make sure you have all input files and namelist.input is correctly set. For more information of namelist.input, read README.namelist in the Doc directory.

You can check a filename by putting a print statement for a file name before line 42 in plotfmt.f.


I found where we can build plotfmt.



I compile plotfmt with our 64-bit compiler and run it on fedora7 system. This is the latest fedora system we have available. It works just fine with empty file. Unfortunately we don’t have fedora 8 system to test yet.

I look at plotfmt.F and don’t see anything that would cause a program fail to open a file.


Dear Hongyon,
Thank you for your trying on fedora.
On CentOS 5, completely same error happened:
plotfmt was compiled successfully, but could not be used to open the output from MM5.
I have read through the file but there is nothing special in plotfmt.f where error was pointed out.


Is the error the same? If it is the same as you posted in the first message then it is because the file name is empty string and hence the error.

The error from the open statement is actually at line 40 or something around that.

To debug it, add a line "print *, “FILENAME IS:”, flnm
before that open statement.

If the flnm is empty string, then the error comes from getarg. Since we have not tested out compiler on fedora 8 or centOS 5, I really can’t say what the problem.

If it prints correct filename but fails to open, then check your input file, i.e., its format, its existence, its location, its permission, its name, etc.