ERROR: Unable to load info from any available system


I try to install NVIDIA X Server Settings but the best I could do is to have an empty windows.
I have tried many things like:

  • sudo apt purge *nvidia* && sudo apt-get remove nvidia* && sudo apt autoremove && sudo apt-get install dkms build-essential linux-headers-generic && sudo vim /etc/modprobe.d/blacklist.conf
  • sudo apt install nvidia-driver-470
  • sudo apt install nvidia-prime && sudo prime-select nvidia
  • sudo ./

Everything installs properly but I run:

$ /usr/bin/nvidia-settings

ERROR: Unable to load info from any available system
$ uname -a
Linux primtux 5.4.0-125-generic #141-Ubuntu SMP Wed Aug 10 13:42:03 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Do you have any idea?

nvidia-bug-report.log.gz (86.0 KB)

[ 112.816546] NVRM: GPU 0000:00:05.0: RmInitAdapter failed! (0x22:0x56:667)
The gpu might be broken.
Please try to reseat card in its slot, check in another system for a general hardware failure.

Thanks for your speed.

This O.S. is running in a Virtual Machine under Unraid, could this be because the graphics card ROM has to be modified to be accepted, by removing the NVIDIA header, or is this unrelated?

Ok, I didn’t check for a VM. This is very well possible the init failure is tied to pci passthrough, though it should work without fiddling with drivers >460 since uraid is based on KVM.
VBios modifications are not necessary, you could try using the old workaround, hiding the hypervisor.