Nvidia-settings - ERROR: Unable to load info from any available system

Hello,

The issue I report looks common thing, I went through other threads suggesting solutions, unfortunately to no avail.

I run Ubuntu 18.04 on Lenovo IdeaPad L340 equipped with GTX 1650.

I want to control GPU fan speed.

I installed NVIDIA drivers with ubuntu-drivers autoinstall.

When I run nvidia-settings command I receive ‘ERROR: Unable to load info from any available system’ message. NVidia X Server Settings open with blank screen.

I have Secure Boot disabled.

Please help.

Thank you,
Val

nvidia-bug-report.log.gz (666.6 KB)

sudo prime-select nvidia

returns ‘Info: the nvidia profile is already set’

There’s a config file missing that sets the path to the nvidia module, please create
/etc/X11/xorg.conf.d/10-nvidia.conf

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection
1 Like

Hello,

Thank you for the solution, it definitely works. Now I am able to access NVidia X Server Settings app.

However, the part about ‘Coolbits’ (to be able to control fan speed) does not work. I added ‘Option “Coolbits” “28”’ to 10-nvidia.conf file, so it looks now as

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "Coolbits" "28"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection

Still, fan speed option is missing in NVidia X Server Settings (Thermal Settings).

Command line
nvidia-settings -a ‘[gpu:0]/GPUFanControlState=1’
returns
ERROR: Error parsing assignment ‘‘[gpu:0]/GPUFanControlState=1’’ (Trailing
garbage).

Please advise how can I make fan speed control working.

Thank you,
Val

wrong quoting.
Use either “whatever” or ‘whatever’. Not ´whatever´.

1 Like

However, fan control in nvidia-settings is very limited. Just static.
This tool i.e. will give you the ability to set a fan curve:

Thank you, Mart,

“” quoting worked for me, at least with first of the instructions. My bad, I had to figure it out myself if I read those other threads more carefully.

However, the second one
nvidia-settings -a "[fan:0]/GPUTargetFanSpeed=25"
fails with message
‘ERROR: Error resolving target specification ‘fan:0’ (No targets match target
specification), specified in assignment ‘[fan:0]/GPUTargetFanSpeed=25’’

Which still leaves me confused as to how to make fan speed control work with command line.

Please help.
Thank you,
Val

Laptops have no gpu controlled fans. All fans are controlled by system bios.

1 Like

Thank you,

That clears thing a lot.

I’ll then take a look at BIOS settings.

Best regards,
Val

Here’s a thread with some more info about dual-fan designs:
https://forums.developer.nvidia.com/t/how-to-set-gpu-fan-speed/71621
This was included for Thinkpads in kernel 5.8, don’t know if this can be made use of on Ideapads. Maybe check with the thinkpad-acpi mailing-list.