problem with nvidia-setting

Dear Nvidia,
I have a system with 3 GPU (2 gtx1070 and one titanV). I had few problems with the installation but now all looks good (cuda works and nvidia-smi) as well but I can not start nvidia-settings
if i run from terminal


I get

ERROR: Unable to load info from any available system

. however, as i just mantioned



Fri Oct 25 09:55:38 2019
| NVIDIA-SMI 418.87.01    Driver Version: 418.87.01    CUDA Version: 10.1     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 1070    On   | 00000000:3B:00.0  On |                  N/A |
|  0%   44C    P8     6W / 151W |     94MiB /  8119MiB |      0%      Default |
|   1  GeForce GTX 1070    On   | 00000000:86:00.0 Off |                  N/A |
|  0%   38C    P8     6W / 151W |     18MiB /  8119MiB |      0%      Default |
|   2  TITAN V             On   | 00000000:AF:00.0 Off |                  N/A |
| 45%   63C    P2   134W / 250W |   3478MiB / 12036MiB |     90%      Default |

| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0      3727      G   /usr/lib/xorg/Xorg                            27MiB |
|    0      3768      G   /usr/bin/gnome-shell                          63MiB |
|    1      3727      G   /usr/lib/xorg/Xorg                             5MiB |
|    2      3727      G   /usr/lib/xorg/Xorg                             5MiB |
|    2      6914      C   guppy_basecaller                            3459MiB |

how can i fix the problem? my system is

VERSION="18.04.3 LTS (Bionic Beaver)"
PRETTY_NAME="Ubuntu 18.04.3 LTS"

nvidia-bug-report.log.gz (2.73 MB)

If you’re running over ssh, you’ll have to set the DISPLAY variable (or use nvidia-settings options) to tell which screen to use, e.g
DISPLAY=:0.0 nvidia-settings -q all
The user which runs that command also has to have access permissions to the xserver.

How do I know which DISPLAY to use. Additionally, if i run gedit or other application with GUI interface, I can open them

Do you log in locally at the system and run the command from desktop?

I run the command from SSH session

Please post the output of
ps aux |grep X

here you are

root      3727  0.0  0.0 284920 46408 tty1     Sl+  09:23   0:00 /usr/lib/xorg/Xorg vt1 -displayfd 3 -auth /run/user/121/gdm/Xauthority -background none -noreset -keeptty -verbose 3
lfaino    5665  0.0  0.0 1501536 37080 ?       Sl   09:26   0:01 /usr/lib/xorg/Xorg :12 -auth .Xauthority -config xrdp/xorg.conf -noreset -nolisten tcp -logfile .xorgxrdp.%s.log
lfaino    8361  0.0  0.0  21532  1052 pts/1    R+   13:53   0:00 grep --color=auto X
lfaino    9976  3.6  0.8 20987716 1183572 pts/0 Sl  09:34   9:30 /snap/pycharm-professional/159/jbr/bin/java -classpath /snap/pycharm-professional/159/lib/bootstrap.jar:/snap/pycharm-professional/159/lib/extensions.jar:/snap/pycharm-professional/159/lib/util.jar:/snap/pycharm-professional/159/lib/jdom.jar:/snap/pycharm-professional/159/lib/log4j.jar:/snap/pycharm-professional/159/lib/trove4j.jar:/snap/pycharm-professional/159/lib/jna.jar -Xms128m -Xmx2048m -XX:ReservedCodeCacheSize=240m -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -XX:CICompilerCount=2 -Djdk.http.auth.tunneling.disabledSchemes="" -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Djdk.attach.allowAttachSelf -Dawt.useSystemAAFontSettings=lcd -Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine -XX:ErrorFile=/home/lfaino/java_error_in_PYCHARM_%p.log -XX:HeapDumpPath=/home/lfaino/java_error_in_PYCHARM.hprof -Didea.paths.selector=PyCharm2019.2 -Djb.vmOptionsFile=/home/lfaino/.PyCharm2019.2/config/pycharm64.vmoptions -Didea.platform.prefix=Python com.intellij.idea.Main
lfaino   34078  0.0  0.0 103168 30848 pts/4    S+   11:25   0:03 python3 /home/lfaino/lfainoData/Xylella/repository/xylella/ -f xYLELLA_3.fastq -f5 xYLELLA_3_dem/barcode08/ -t 70

I do not know if this other problem is related but only my user can open GUI application via SSH all the other users can not

You’re running inside a xrpd session, which is a virtual xserver running in software, not a real one running on hardware. You can use nvidia-settings only on xservers which are running the nvidia driver.
The real xserver that is running on the nvidia gpu is the gdm login on the local console. You should be able to use nvidia-settings cli like

  1. get a root shell
    sudo -s
  2. run nvidia settings:
    DISPLAY=:0.0 XAUTHORITY=/run/user/121/gdm/Xauthority nvidia-settings -q all

The problem is that since yesterday (actually yesterday I realized) i can not login. I got stuck in a loop of inserting password. the only way to get in is via xrpd session

According to the logs, you had a reboot this morning. Previously, the xserver was crashing due to misconfiguration.
Does local login work now?

I do not know. I`m not at work. I may check on Tuesday. Another question is, not all users can use GUI application. I get this error

X11 connection rejected because of wrong authentication.
Unable to init server: Could not connect: Connection refused

however, I can open software like gedit or pycharm using my account or root account
do you think that all these problems are related?

The question is
run where?
inside xrdp? sounds like a missing .Xauthority file or an unset DISPLAY variable.
Running on a forwarded X connection on the client Xserver? might be X11Forwarding is not enabled in the ssh client.
This is just too little information, you’ll have to check what you run where, get familar with the DISPLAY variable and xauth command , XAUTHORITY variable and Xauthority file.
Manipulating those can make nvidia-settings gui run on the xrdp’s virtual display :10 while controlling the nvidia gpu of the real display :0.