ERROR: Unable to load the kernel module 'nvidia.ko'

Kernel module load error: No such device
-> Kernel messages:
NVRM: installed in this system is not supported by the
NVRM: NVIDIA 390.25 driver release.
NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
NVRM: in this release’s README, available on the operating system
NVRM: specific graphics driver download page at www.nvidia.com.
[108285.019343] nvidia: probe of 0000:0d:00.0 failed with error -1
[108285.019420] nvidia 0000:0e:00.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=none:owns=none
[108285.019440] NVRM: The NVIDIA GPU 0000:0e:00.0 (PCI ID: 10de:1e04)
NVRM: installed in this system is not supported by the
NVRM: NVIDIA 390.25 driver release.
NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
NVRM: in this release’s README, available on the operating system
NVRM: specific graphics driver download page at www.nvidia.com.
[108285.019496] nvidia: probe of 0000:0e:00.0 failed with error -1
[108285.019574] nvidia 0000:0f:00.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=none:owns=none
[108285.019594] NVRM: The NVIDIA GPU 0000:0f:00.0 (PCI ID: 10de:1e04)
NVRM: installed in this system is not supported by the
NVRM: NVIDIA 390.25 driver release.
NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
NVRM: in this release’s README, available on the operating system
NVRM: specific graphics driver download page at www.nvidia.com.
[108285.019651] nvidia: probe of 0000:0f:00.0 failed with error -1
[108285.019674] NVRM: The NVIDIA probe routine failed for 10 device(s).
[108285.019675] NVRM: None of the NVIDIA graphics adapters were initialized!
[108285.019810] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237

the nvidia-smi works well when the devices was sent to me. The nvidia-smi were installed, and it worked well. Once it was broken, I decided to reinstall it the error appeared. The last way to solve this is to reinstall the system.the system now is ubuntu 18. can anyone help me ?

You have an RTX 2080Ti, which needs at least driver 410.57 but you installed the v390 legacy driver. Please start the Software&Drivers application and select to install the v430 driver.

thx, ur right