Error with CUDA9.1 and maybe CUBLAS(?)

Hi all,

For the past two months I have been trying to setup CUDA on my computer, but the setup seems not completely successful. When I install CUDA, installation finishes without an error. However, I need CUDA for another program and upon using that program, I receive a CUDA-related error. I don’t have any experience with CUDA, but I think CUBLAS is the source of the problem.

Has someone seen this before or does anyone know how to find the source of this problem and maybe how to fix it?

Computer specifications:

  • Ubuntu 18.04 dual boot alongside Windows 10 (two seperate drives from 500GB each)
  • GPU: Quadro T1000
  • driver version 460.32
  • CUDA 9.1 installed

Small part of the initial error with FSL (v6.0, the program I use):

EDDY:::  EddyInternalGpuUtils::make_XtX_cuBLAS: cublasSsyrk error

I ran some sample code and found that one CUBLAS sample resulted in an error.
The following samples all passed:

$ ./deviceQuery
$ ./bandwidthTest
$ ./simpleCUBLAS
$ ./batchCUBLAS
$ ./matrixMulCUBLAS
$ ./simpleCUBLASXT

But this sample did not succeed:

$ ./simpleDevLibCUBLAS
simpleDevLibCUBLAS test running...
MapSMtoCores for SM 7.5 is undefined.  Default to use 64 Cores/SM
GPU Device 0: "Quadro T1000 with Max-Q Design" with compute capability 7.5

Host and device APIs will be tested.
!!!! device to host memory copy error

Likely problem: The Quadro T1000 has compute capability 7.5 (Turing architecture), but CUDA 9.x only supports up to compute capability 7.0. Install a newer CUDA version that has support for compute capability 7.5. Currently, the latest version is CUDA 11.2.

There is also a possibility of some sort of conflict with CUDA-accelerated apps, although that usually works the other way around. Concrete example: After I installed CUDA 11.1 on my system the CUDA acceleration in Folding@Home (built against an older CUDA version) stopped working. In my understanding this should not happen when CUDA apps follow NVIDIA recommended best practices.

Thanks for your clear explanation, the problem is indeed the compute capability. Unfortunately, FSL requires CUDA 9.1 or 8.0 and therefore I cannot update it to 11.2.

I did find a (partial) solution, if anyone has the same problem:
FSL v6.0.4 uses CUBLAS, but this was only introduced in this version to speed-up slice-to-volume correction. v6.0.3 does not require CUBLAS, but it takes longer to run. FSL is aware of this problem and hopefully, this will be fixed in future releases.

Hello Asvsr,

It seems I have a similar issue as yourself GeForce RTX 2060, Driver Version: 460.73.01 GPU which has a compute capability of 7.5 versus the maximum compute capability of cuda 9.1 of 7.0.

I get the same error in your previous post

To be clear, what was your partial fix? I believe I need FSL v6.0.4 to use the –b0_only flag in eddy.

My attempt at a solution was to try and install a specific version of eddy to work with cuda 11.3 (another example), but did not have any success.

Hi johann997,

For my problem, the solution was to install FSL version 6.0.3 (I didn’t use the --b0_only flag). Unfortunately, if --b0_only requires v6.0.4, this would not work for you.
I didn’t know it was possible to install a specific version of eddy to match your CUDA version. Therefore, I’m afraid I can’t help you with this.