TensorRT 3.0 installation with CUDA Toolkit 9.1 cuBLAS error

I downloaded TensorRT 3.0 for Ubuntu 16.04 and CUDA 9.0 DEB local repo packages but I get an error with the CUDA Toolkit 9.1 when I tried to install.

sudo apt-get install tensorrt

tensorrt : Depends: libnvinfer4 (>= 4.0.1) but it is not going to be installed

sudo apt install libnvinfer4

libnvinfer4 : Depends: cuda-cublas-9-0 but it is not installed

With the new CUDA version the cuda-cublas-9-1 is installed.

How to fix it?

I’ve got the same problem…

Edit: I used the TAR to install TensorRT and then it seems to work. Except that the tensorrt samples can’t be run because they require libcublas.so.9.0 and libcudart.so.9.0, whereas I only have libcublas.so.9.1 and libcudart.so.9.1

Also, when trying to import tensorrt in Python I get this error: ImportError: libnvinfer.so.4: cannot open shared object file: No such file or directory

So it seems the installation wasn’t very succesfull after all. Should I just install an older Cuda version…?


We have the same issues. CUDA 9.1 is required to solve certain issues, but TensorRT doesn’t seem to support 9.1! What’s the workaround?

I have the exact same issue, even though I do have Cuda 9.0, and specifically
libcublas.so.9.0 and libcudart.so.9.0 are both present

anyone has a solution?

You should be able to install all versions of cuBLAS at the same time. Such as:

$ dpkg-query -W | grep cuda-cublas
cuda-cublas-9-0 9.0.176-1
cuda-cublas-9-1 9.1.85-1
cuda-cublas-dev-9-0 9.0.176-1
cuda-cublas-dev-9-1 9.1.85-1

Which repo did you use to install cuda-cublas-9-1?

Also having this issue despite having cuda 9.0

If I am not mistaken you may choose to install cublas installing cuda-toolkit .run file. Otherwise you may get it from https://developer.nvidia.com/cublas.
You may also need to export paths.
For reference: https://www.nvidia.com/en-us/data-center/gpu-accelerated-applications/tensorflow/

If you are using a local repo (deb local) you may run into that problem. I’d suggest using the network repo since it’s the easiest option.


I am running into the same issue. I installed the local repo for deb installation. I am not sure how to resolve this.

TensorRT does not support CUDA 9.1. You will either need CUDA 9.0 if you want to continue to use TensorRT 3.0 or you can use CUDA 9.2 if you want to use TensorRT 4.0.