TensorRT was linked against cuBLAS/cuBLAS LT 11.3.0 but loaded cuBLAS/cuBLAS LT 11.2.1

Description

When I run the sampleMNIST application located in TensorRT-7.2.2.3/samples/ I get an error
TensorRT was linked against cuBLAS/cuBLAS LT 11.3.0 but loaded cuBLAS/cuBLAS LT 11.2.1
I had installed CUDA 11.2, so I also installed CUDA 11.1 as given in requirements.
I set the $PATH to cuda 11.1 and $LD_LIBRARY_PATH to 11.1 lib location.
I have also set path to TensorRT-7.2.2.3 lib in $LD_LIBRARY_PATH.
What am I missing?

Environment

Ubuntu 20.4

TensorRT Version: 7.2.2.3
GPU Type: T4
Nvidia Driver Version: 460
CUDA Version: 11.1
CUDNN Version: 8.0.3
Operating System + Version: Ubuntu 20.4
Python Version (if applicable):
TensorFlow Version (if applicable):
PyTorch Version (if applicable):
Baremetal or Container (if container which image + tag):

Relevant Files

Please attach or include links to any models, data, files, or scripts necessary to reproduce your issue. (Github repo, Google Drive, Dropbox, etc.)

Steps To Reproduce

Please include:

  • Exact steps/commands to build your repro
  • Exact steps/commands to run your repro
  • Full traceback of errors encountered
1 Like

Hi @mehul.vast,
Can you please validate your installation steps with the following guide.

Also we recommend you to use the NGC container so as to avoid any system level dependency.

Thanks!

Same problem. Did you solve it?

No, not yet. You have any idea about it?

Setting the PATH and LD_LIBRARY_PATH to cuda 11.2 worked to remove that warning. However I still can’t execute the sampleMNIST application. I have this error:

terminate called after throwing an instance of ‘pwgen::PwgenException’
what(): Driver error:

is it the same for you?

No, not the same. What did you follow for installation of dependencies? Runfile, TAR or DEB? for CUDA, cuDNN?
It has something to do with the installations followed.

Hi @mehul.vast ,
We recommend you to try NVIDIA GPU Cloud (NGC) tensorrt optimized containers, which removes many of the host-side dependencies.

Thanks!

I tried to follow the guide to install Deepstream as best I could but yet here I am with this error also.

have you solve it? I meet the same error.

@2511858125 Check the Compatibility matrix of deepstream properly. Every version has to be intact