Fail to run sample_mnist after installing TensorRT

I was installing TensorRT on Ubuntu 16.04 64-bit, with CUDA 8.0 and cuDNN. I was installing using dpkg on .deb files. The installation looks fine until I tried to verify sample application. When I ran ./sample_mnist in bin folder, it reported:

*** Error in `./sample_mnist’: free(): invalid next size (fast): 0x00007fbe8cbfc5e0 ***
======= Backtrace: =========

======= Memory map: ========

Guessing something bad in environmental dependencies. Is there any hint to me what was wrong? or advice?
Thanks a lot!


Hello, can you provide details on the platforms you are using?

GPU type
Driver version

have you tried this using nvidia trt container?

I meet same problem.My platform include :
GPU type:GTX1070 ;
NVRM version: NVIDIA UNIX x86_64 Kernel Module 384.130 Wed Mar 21 03:37:26 PDT 2018
GCC version: gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.10)
cuda 8.0
have you solved it?I holp you will not hesitate to give me some advices.Thanks.

Hi Moderator,

I was using Geforce 1080Ti card, and installed driver from PPA under Ubuntu 16.04:
sudo add-apt-repository ppa:graphics-drivers/ppa
The driver version it showed was 390.xx.

However, after I installed this driver and went on installing CUDA toolkit 8.0, seemed it included GPU driver by itself and automatically installed another driver during the installation as I remembered.

And then I installed cuDNN 5.1 for my OpenPose project dependency, and then cuDNN 7.2 for TensorRT 4 dependency.

I was using the way of .deb installation for both CUDA and cuDNN.

I’m not sure where could be the fault, plz help to give some advice.

can you try NVIDIA Tensorrt container?

It is a self-contained environment that has all the necessary libraries and dependencies. It comes with the examples.