tensorRt installation fails w cuda9.1 / cuDNN 7.0.5

sudo apt install tesnorrt

returns

Some packages could not be installed …
… unmet dependencies:
tensorrt : Depends: libnvinfer4 (>= 4.0.2) …

and I guess it is because this is not compatible w cuda9.0

I am seeing the same issues - When installing libnvinfer4 with

sudo apt-get install libnvinfer4

it says

The following packages have unmet dependencies:
 libnvinfer4 : Depends: cuda-cublas-9-0 but it is not installable

I have cuda-cublas-9-1 installed

Same problem here