TensorRT installation issue, when rolling back from cuda 10.2 to 10.1

RTX 2070, CUDA 10.1.243(update2), TensorRT 6.0.1.5

Using the deb package method for installation from https://docs.nvidia.com/deeplearning/sdk/tensorrt-archived/tensorrt-601/tensorrt-install-guide/index.html, and when doing

sudo apt-get install tensorrt

These are the unmet dependencies that I face…

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tensorrt : Depends: libnvinfer6 (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-plugin6 (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvparsers6 (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvonnxparsers6 (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-bin (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-dev (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-plugin-dev (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvparsers-dev (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvonnxparsers-dev (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-samples (= 6.0.1-1+cuda10.2) but it is not going to be installed
            Depends: libnvinfer-doc (= 6.0.1-1+cuda10.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Is there any resolution to the above?

Guess, it was a simple configuration mistake of not deleting the apt’s package manager local repositories of the previous CUDA_10.2’s debian installation packages from “/etc/apt/sources.list.d” folder.

Just had to remove “nv-tensorrt-cuda10.2-trt6.0.1.8-ga-20191108.list” from the above path