External PPS not triggering fsync generator

Hi @VickNV

I tried running the nvsipl_camera app as following command:
sudo ./nvsipl_camera -c HZKJ_IMX728_ES2_V2_120FOV_CPHY_x4 -m “1000 0 0 0” -sR -v 4 -D ‘2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2’ -U ‘10 a c’ --nvsci

Below is the result of that. I get 0 frames.
nvsipl_log.txt (82.7 KB)

I got above command with reference to below links

Currently, I see that the gpio is triggered. My interrupt list is showing increments with every pulse that is fed.
335: 1047 0 0 0 0 0 0 0 0 0 0 0 c2f0000.gpio 29 Edge nvpps_isr

My dmesg looks as below:
nvidia@tegra-ubuntu:~$ sudo dmesg | grep gpio
[sudo] password for nvidia:
[ 0.199990] input: gpio-keys as /devices/platform/gpio-keys/input/input0
[ 1.380195] nvpps c6a0104.nvpps: gpio_pin(509)
[ 1.380234] nvpps c6a0104.nvpps: gpio_to_irq(335)
[ 1.388033] nvethernet 2310000.ethernet: failed to get phy reset gpio error: -2
[ 1.393967] nvethernet 6810000.ethernet: failed to get phy reset gpio error: -2
[ 1.401517] nvethernet 6910000.ethernet: failed to get phy reset gpio error: -2
[ 1.411907] nvethernet 6a10000.ethernet: failed to get phy reset gpio error: -2
[ 1.420219] nvethernet 6b10000.ethernet: failed to get phy reset gpio error: -2
[ 193.619529] cdi-mgr sipl_devblk_0: cdi_mgr_gpio_intr_wait: wait_event_interruptible failed -512
[ 259.112981] cdi-mgr sipl_devblk_0: cdi_mgr_gpio_intr_wait: wait_event_interruptible failed -512

This seems to be th reason deserialiser may not be triggered. But I am unaware what am i doing wrong.

Can you please suggest some steps to resolve this issue?

@SivaRamaKrishnaNV Any inputs from your end would also be really helpful. I am stuck on this issue from a long time.