External SSD name change for every openning time

Hello,

I have Jetson TX2 Developer board and Elroy Carrier Board with jetson TX2 module. When i connect external SSD to developer board, SSD’s name not change and always same. But Elroy Carrier Board’s jetson change SSD name for every openning time. For example, i gave name it which was “test”. Then i did shut down and open operation to carrier board’s jetson. After that, the SSD name has already changed with “test1”. This bug goes on all the time like test1,test2 and so. Developer board works fine. But Elroy Carrier Board’s jetson not work as i expected.

What is the reason for it?

Best Regards.

What kind of SSD connection is used? For example, SATA versus external USB?

Where is the SSD mounted (what is the directory mount point)?

When the SSD is connected, what do you see from:

lsblk -f -a

I have a mSATA SSD. I connected it directly to mSATA input.

The result of command is given below.

nvidia@tegra-ubuntu:~$ lsblk -f -a
NAME         FSTYPE LABEL UUID                                 MOUNTPOINT
sda          ntfs   Test  7BA60E87226AA5F4
loop0
loop1
loop2
loop3
loop4
loop5
loop6
loop7
mmcblk0rpmb
mmcblk0boot0
mmcblk0boot1
mmcblk0
+¦mmcblk0p1  ext4         f3a27c72-c64f-4d65-8950-46621c788a91 /
+¦mmcblk0p2
+¦mmcblk0p3
+¦mmcblk0p4
+¦mmcblk0p5
+¦mmcblk0p6
+¦mmcblk0p7
+¦mmcblk0p8
+¦mmcblk0p9
+¦mmcblk0p10
+¦mmcblk0p11
+¦mmcblk0p12
+¦mmcblk0p13
+¦mmcblk0p14
+¦mmcblk0p15
+¦mmcblk0p16
+¦mmcblk0p17
+¦mmcblk0p18
+¦mmcblk0p19
+¦mmcblk0p20
+¦mmcblk0p21
+¦mmcblk0p22
+¦mmcblk0p23
+¦mmcblk0p24
+¦mmcblk0p25
+¦mmcblk0p26
+¦mmcblk0p27
+¦mmcblk0p28
L¦mmcblk0p29

I see the label, but how are you testing the change? Does the label change is “lsblk -f -a”, or is there different criteria?

I have attached a link which shows my problem.

https://i.hizliresim.com/al1pr5.png

The URL says access is forbidden…no way to view the image (perhaps you have a cookie set that allows you to see it, or are otherwise logged in).

Could you please try to open this URL?

https://ibb.co/djGpcYG

I do not know how to upload an image here from my local pc. So i uploaded it a different web site. Then putted it here.

To attach a file (such as image) you have to edit an existing post. Hover the mouse over the quote icon in upper right and a paper clip icon shows up. The paper clip icon is how you attach. Can’t do it while creating a post.

Looks like the drive is being auto mounted. This is a feature of Ubuntu (and most distributions) rather than being something custom to a Jetson. It seems some Linux distributions count an M.2 SSD as removable media. If you run this command I think this is a list of related settings:

gsettings list-recursively org.gnome.desktop.media-handling

I found this through this explanation:
https://unix.stackexchange.com/questions/282918/how-can-i-use-gsettings-to-disable-device-automount-in-ubuntu-16-04

Disable was listed as (perhaps requiring sudo…I didn’t test):

gsettings set org.gnome.desktop.media-handling automount false

However, you might not want to completely disable all automount. Notice that the label is not a directive for mounting, although some software will take hints. Do you want this to always mount on boot on a particular spot? Are you going to treat this as a non-removable device (i.e., like a regular hard drive)? If so, then you could provide an overriding mount directive for that device or for that specific partition of the device. As long as you don’t remove the specific partition the UUID will be constant. In your case the “lsblk -f” shows this UUID for the NTFS partition:

7BA60E87226AA5F4

The “/media” location is usually used for automount, and you can use mount directives there, but it doesn’t have to be in any particular location. I’ll assume you want this to always mount at a more traditional location, e.g., “/usr/local/ssd/”. You can edit that spot and move it to somewhere in “/media/Test/” as another possibility, but if you were to append the following line in “/etc/fstab” (just edit this with sudo, e.g., “sudo gedit /etc/fstab”), then this partition would always mount in that location:

# sudo mkdir /usr/local/ssd
# sudo gedit /etc/fstab
# ...now the edits...
UUID=7BA60E87226AA5F4  /usr/local/ssd   NTFS   defaults  1 2

In this line for UUID the “1” implies that backup tools will see the drive. If you have some backup system and wanted this to not be backed up you’d change it to “0”. The “2” means that during boot this is the second fsck to be done if fsck is needed (the primary root partition which this mounts on is “1”…parents get fsck when needed prior to child mounts). Note that for Ubuntu to fix an NTFS drive you need package “ntfs-3g”. If you don’t have ntfsfix (command to test: “which ntfsfix”), then:

sudo apt-get install ntfs-3g

There are variations on this, e.g., I have a windows disk I specify the mount location as “/win_c”, but it doesn’t automount…whenever I “mount /win_c” it does the right thing. Another option might be to specify who owns the mounted partition…automount sets this to whoever plugged in the hotplug device while logged in to the GUI. NTFS is special because it does not contain any Linux file system ownership content and is completely alien to the Linux kernel.