fail with linpack benchmark on p4 arch

Hi,

I tried to determine the linpack mflops value on p4 arch with latest pgi compiler. However, I got “inf” all the time, no matter how large the matrix size is. hereafter the simple compilation flags adopted:

FC = pgf90 -fastsse -tp p7 -Minfo=all
CC = pgf90 -fastsse -tp p7 -Minfo=all

std log of linpack:

norm. resid resid machep x(1) x(n)
6.49150133E+00 7.20701276E-13 2.22044605E-16 1.00000000E+00 1.00000000E+00


times are reported for matrices of order 1000
factor solve total mflops unit ratio
times for array with leading dimension of1001
0.000E+00 0.000E+00 0.000E+00 inf 0.000E+00 0.000E+00

any suggestion?
Thanks in advance.

BR,
J

Hi Jason,


What happens when you scale back optimization? Try “-O2” and “-O2 -Mscalarsse” to determine if its a x87 vs SSE precision issue and “-fast -Mscalarsse -Mcache_align” to is if its a problem with SSE vectorization ("-Mvect=sse").

Are you using the standard NetLib linpack? or some other package?

  • Mat

Hi Mat,

Thanks for the feedback, however, I am dealing with p4 arch, I am wondering why fastsse fail. I’ve tried both reducing the optimization level as -O2 as well as adding -Mscalarsse, both are fail with inf mflops values.

BTW,
after tried with couple of compilation flags, I found raising all real variables into double precision will resolve the problem, now I can have clear picture of mflops values versus matrix size using PGI c/f90 compilers.

Thanks for the help Mat. :-)

BR,
J