Failed mnistCUDNN test

After installation of cudnn I ran this mnistCUDNN test. And I got the following error:

cudnnGetVersion() : 7605 , CUDNN_VERSION from cudnn.h : 7605 (7.6.5)
Host compiler version : GCC 5.4.0
There are 1 CUDA capable devices on your machine :
device 0 : sms 36 Capabilities 7.5, SmClock 1185.0 Mhz, MemSize (Mb) 7952, MemClock 6001.0 Mhz, Ecc=0, boardGroupID=0
Using device 0

Testing single precision
Cublas failure
Error code 1
mnistCUDNN.cpp:404
Aborting…

I’m working on the Ubuntu 16.04 with cuda 10.1. The driver version for my RTX2070 maxq is 418.56. The cudnn version as you can see from the output is 7.6.5.

And I checked this mnistCUDNN.cpp file. The code in the line 404 is:
checkCublasErrors( cublasCreate(&cublasHandle) );
which indicates that I got the error during creating the cublas handle.

Does any of you guys have similar problems? Please someone help me out! Thanks!

solved with symlink:
$sudo ln -s /usr/lib/x86_64-linux-gnu/libcublas.so.10.1.0.105 /usr/local/cuda/lib64/libcublas.so.10
$sudo ln -s /usr/lib/x86_64-linux-gnu/libcublasLt.so.10.1.0.105 /usr/local/cuda/lib64/libcublasLt.so.10

1 Like