Failed to bind input tensor

Hi, this happened when i tried to build the tensorrt engine with dla-enabled from yolov5s onnx model using trtexec.

Module_id 33 Severity 2 : NVMEDIA_DLA 684
Module_id 33 Severity 2 : Failed to bind input tensor. err : 0x00000b
Module_id 33 Severity 2 : NVMEDIA_DLA 2866
Module_id 33 Severity 2 : Failed to bind input tensor args. status: 0x000007
[04/20/2022-17:37:49] [I] [TRT] [MemUsageChange] Init cuBLAS/cuBLASLt: CPU +0, GPU +0, now: CPU 986, GPU 4586 (MiB)
[04/20/2022-17:37:49] [E] Error[1]: [nvdlaUtils.cpp::submit::198] Error Code 1: DLA (Failure to submit program to DLA engine.)
[04/20/2022-17:37:49] [E] Error[2]: [builder.cpp::buildSerializedNetwork::417] Error Code 2: Internal Error (Assertion enginePtr != nullptr failed.)

Dear @user157739,
Could you share model, command, Jetpack versions for reproduce the issue.

Sure, thanks.

model: yolov5s.onnx - Google Drive
Jetpack Version: 4.6
Command: /usr/src/tensorrt/bin/trtexec --onnx=/home/txm/Downloads/yolov5/models/yolov5s.onnx --fp16 --streams=2 --avgRuns=1 --iterations=4 --saveEngine=/home/txm/Downloads/yolov5s_fp16_DLA_0.engine --useDLACore=0 --allowGPUFallback

Dear @user157739,
I don’t see any issue with Jetpack 4.6.1(TensorRT 8.2.1) for your shared model. Could you check?

Alright thanks. Is it working well on Jetpack 4.6.1 only? Because currently im with Jetpack 4.6 (TensorRT 8.0.1)

Dear @user157739,
Yes. It is working well on Jetpack 4.6.1. Please consider upgrading if possible.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.