failed to burn image emmc to nano board

Hi tpwang2000,

Please check the #16, I have provide the ecosystem partners link.
https://devtalk.nvidia.com/default/topic/1061275/jetson-nano/jetson-nano-module-available-now/post/5374344/#5374344

Yes, because those vendors sell the carrier board separately.

For example,
https://leopardimaging.com/product/nvidia-jetson-cameras/nvidia_nano_mipi_camera_kits/li-nano-cb/

today I use SDKManager to burn image on Jetson-Nano for the core board with sd card (Jetson Nano Developer Kit:180-13449-DAAF-A02+180-13448-A02).
but I also can not start the kernel;

why?

uart log:

In: serial
Out: serial
Err: serial
Net: No ethernet found.
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1…
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
733 bytes read in 87 ms (7.8 KiB/s)
L4T boot options
1: primary kernel
Enter choice: 1: primary kernel
Retrieving file: /boot/initrd
5562303 bytes read in 296 ms (17.9 MiB/s)
Retrieving file: /boot/Image
34179080 bytes read in 1530 ms (21.3 MiB/s)
append: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,2 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 quiet

Flattened Device Tree blob at 83100000

Booting using the fdt blob at 0x83100000
reserving fdt memory region: addr=80000000 size=20000
Using Device Tree in place at 0000000083100000, end 0000000083177282

Starting kernel …

[ 1.036373] tegradc tegradc.1: dpd enable lookup fail:-19 [ 1.547869] Host read timeout at address 545c00c4 [ 1.738467] imx219 6-0010: imx219_board_setup: error during i2c read probe (-121) [ 1.746034] imx219 6-0010: board setup failed [ 2.641380] cgroup: cgroup2: unknown option "nsdelegate" [ 3.776025] using random self ethernet address [ 3.781385] using random host ethernet address [ 3.815957] using random self ethernet address [ 3.821136] using random host ethernet address [ 4.081811] random: crng init done [ 4.085218] random: 7 urandom warning(s) missed due to ratelimiting [ 10.158366] Please complete system configuration setup on /dev/ttyGS0 to proceed...

Do you connect a HDMI monitor on your board?

[ 10.158366] Please complete system configuration setup on /dev/ttyGS0 to proceed…

I do not connect any display screen;
how can I configuration setup on /dev/ttyGS0,
I can not input anything

Better finding a hdmi monitor and connect it to your port. Are you able to find a HDMI?

If not, please use below script before flashing.
https://devtalk.nvidia.com/default/topic/1054926/jetson-nano/jetson-nano-all-usb-ports-suddenly-stopped-working/post/5356153/#5356153

Hi,ALL:

the Schematics can be provided to me for the carried board(bottom board) of the emmc core board?
where can I download the PCB Schematics for the carried board using the emmc board?
we product the bottom board,then we can use the emmc board and the carried board

https://developer.nvidia.com/embedded/downloads#?tx=$product,jetson_nano

-> Jetson Nano Carrier Board Reference Design Files

Are there some error for the *.img in the Linux_for_Tegra package?
I use “sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1” to burn the sd card;successfuuly
but I can’t the core board;why?

if I want to start the core board , I can use SDKManager to burn the sd card,or use windows tools,

uart log:
[0005.901] Find /i2c@7000c500’s alias i2c2
[0005.905] get eeprom at 3-a0, size 256, type 0
[0005.909] get eeprom at 3-ae, size 256, type 0
[0005.914] pm_ids_update: Updating 1,a0, size 256, type 0
[0005.919] I2C slave not started
[0005.922] I2C write failed
[0005.925] Writing offset failed
[0005.928] eeprom_init: EEPROM read failed
[0005.932] pm_ids_update: eeprom init failed
[0005.936] pm_ids_update: Updating 3,a0, size 256, type 0
[0005.966] pm_ids_update: The pm board id is 3448-0000-200
[0005.973] Adding plugin-manager/ids/3448-0000-200=/i2c@7000c500:module@0x50
[0005.980] pm_ids_update: pm id update successful
[0005.985] pm_ids_update: Updating 3,ae, size 256, type 0
[0006.015] pm_ids_update: The pm board id is 3449-0000-200
[0006.021] Adding plugin-manager/ids/3449-0000-200=/i2c@7000c500:module@0x57
[0006.029] pm_ids_update: pm id update successful
[0006.059] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0006.065] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0006.073] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0006.079] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0006.088] updating /chosen/nvidia,ethernet-mac node 00:04:4b:e5:31:5f
[0006.094] Plugin Manager: Parse ODM data 0x00094000
[0006.104] shim_cmdline_install: /chosen/bootargs: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0006.119] Add serial number:14219190835110008102 as DT property
[0006.128] “bpmp” doesn’t exist, creating
[0006.134] Updated bpmp info to DTB
[0006.139] Updated initrd info to DTB
[0006.142] “proc-board” doesn’t exist, creating
[0006.147] Updated board info to DTB
[0006.151] “pmu-board” doesn’t exist, creating
[0006.156] Updated board info to DTB
[0006.159] “display-board” doesn’t exist, creating
[0006.165] Updated board info to DTB
[0006.168] “reset” doesn’t exist, creating
[0006.173] Updated reset info to DTB
[0006.176] Cmdline: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,2 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 tegra_fbmem=0x800000@0x92cb3000 is_hdmi_initialised=1
[0006.215] DTB cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0006.228] boot image cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0006.241] Updated bootarg info to DTB
[0006.244] Adding uuid 00000001644226c71800000002028100 to DT
[0006.250] Adding eks info 0 to DT
[0006.256] WARNING: Failed to pass NS DRAM ranges to TOS, err: -7
[0006.262] Updated memory info to DTB
[0006.267] Updated system-lp0-disable info to DTB
[0006.275] set vdd_core voltage to 1075 mv
[0006.279] setting ‘vdd-core’ regulator to 1075000 micro volts
[0006.296] could not find regulator
[0006.300] Found secure-pmc; disable BPMP

U-Boot 2016.07-gd917e08cec (Aug 12 2019 - 21:10:20 -0700)

TEGRA210
Model: NVIDIA P3450-Porg
Board: NVIDIA P3450-PORG
DRAM: 4 GiB
MMC: Tegra SD/MMC: 0, Tegra SD/MMC: 1
Using default environment

In: serial
Out: serial
Err: serial
Net: No ethernet found.
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1…
Card did not respond to voltage select!
starting USB…
USB0: tegrausb: Invalid dr_mode 2 for host mode
probe failed, error -1
USB error: all controllers failed lowlevel init
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5
BOOTP broadcast 6
BOOTP broadcast 7
BOOTP broadcast 8
BOOTP broadcast 9
BOOTP broadcast 10
BOOTP broadcast 11
BOOTP broadcast 12
BOOTP broadcast 13
BOOTP broadcast 14
BOOTP broadcast 15
BOOTP broadcast 16
BOOTP broadcast 17

Retry time exceeded; starting again
missing environment variable: pxeuuid
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/01-00-04-4b-e5-31-5f
*** ERROR: serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/00000000 *** ERROR: serverip’ not set
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/0000000
*** ERROR: serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/000000 *** ERROR: serverip’ not set
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/00000
*** ERROR: serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/0000 *** ERROR: serverip’ not set
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/000
*** ERROR: serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/00 *** ERROR: serverip’ not set
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/0
*** ERROR: serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/default-arm-tegra210 *** ERROR: serverip’ not set
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/default-arm
*** ERROR: serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/default *** ERROR: serverip’ not set
Config file not found
starting USB…
USB0: tegrausb: Invalid dr_mode 2 for host mode
probe failed, error -1
USB error: all controllers failed lowlevel init
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5
BOOTP broadcast 6
BOOTP broadcast 7

Concept schematic and OrCAD schematics?

why are there two schematic?which is for the carried board of the emmc board?

I use “sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1” to burn the sd card;successfuuly
but I can’t the core board;why?

You have to use “jetson-nano-emmc” to flash emmc based module.

SD module:jetson-nano-qspi-sd
EMMC module:jetson-nano-emmc

Where do you get this “Linux_for_Tegra”? From the download center? or from the sdkmanager?

Concept schematic and OrCAD schematics?
which is for the carried board of the emmc board?