Failing to Flash to Jetson Orin Nano Dev Kit using SDK Manager and Oracle VM

Hi all,

I’ve been battling against my new Jetson Orin Nano 8GB Dev Kit for a few days now and have finally reached a point where I don’t know how to proceed.

I don’t have access to a Linux-native machine, so I’m running an Oracle VM and have followed all steps shown in this thread.

The process I’m going through to flash is: open SDKmanager with dev kit plugged in and in forced recovery mode (using a jumper between “FC REC” and GND) >>> get through steps 1 and 2 >>> when downloading has finished and final menu screen comes up, remove jumper and select “Manual” mode, with Runtime selected as the OEM configuration and NVMe as the storage device, as per the thread linked above.

I’ve attached the most recent logs. Interestingly on this try, on the final menu window I was prompted to create a new username and password (between “OEM Configuration” and “Storage”), but this option wasn’t there on previous attempts (note that I had just increased the VM’s available RAM from 4GB to 16GB so that might be related).

I massively appreciate any guidance. I’d really prefer to use the SSD for booting rather than a microSD card.


Wouldn’t let me post the link to the forum and the logs, so I’ve added the logs here.
SDKM_logs_JetPack_5.1.1_(rev._1) (160.4 KB)

VM is not supported by SDK manager, it’s better to have a native Ubuntu 20.04 host PC to install the SDK manager to get your device flash via JetPack.
For Orin Nano, you can try with SD card image to boot your device, you can refer to Jetson Orin Nano Developer Kit Getting Started Guide | NVIDIA Developer


we do not officially support flashing on a VM.
If you do need to boot from SSD, you may use the SD card image as mentioned by @kayccc,
make sure it can boot up, and copy the rootfs to the SSD with tools like this:

Thanks for the replies. I tried what @DaveYYY suggested but I’m not sure that it worked, as the system still runs extremely slowly.

Just opening Firefox and making a search takes a good 1-2 minutes.

I’m currently using a 64 GB UHS-I micro SD card (this one) and I’m considering buying a UHS-3 card instead, to hopefully help the extreme slowness.

Do you have any other suggestions for combating slowness, or things that I should check to see what might be causing it? I’m very new to Linux 😬


PS. Apologies for the tardiness. Got caught up in other things and didn’t have a chance to work on this.


you can check CPU usage with htop or jtop:

If you don’t see the CPU usage average at like 50% or more, the the bottleneck is clearly the speed of the SD card.

NVMe SSDs has gotten very cheap recently, and you may consider buy one. They should be way faster than SD cards.

You can also monitor logs with “dmesg --follow”. If some error is going on, then probably you’d see log lines appear as they occur.

Good to know! Thanks for the tips.

As it happens, I went to try both of these this morning and my Jetson refuses to boot… after powering on I get the NVIDIA splashscreen and nothing else. I’ve left it for over an hour and nothing happens… I’ll pick up a faster + bigger microSD and hopefully the system will be usable then.

NVMe SSDs has gotten very cheap recently, and you may consider buy one. They should be way faster than SD cards.

Yep - I’ve got one, and have been trying to get it to be the main boot device, but I don’t have access to a Linux computer. I tried setting up a dual-boot on my PC but it didn’t work. I’m planning on getting a new computer in the next few months (which will be dual-boot) so I’m thinking of just suffering the slow speeds until then.

Whenever you have a boot problem like that, be sure to get a serial console boot log. Serial console logs include boot content from long before the actual Linux kernel ever loads. It’ll show details the local monitor does not show.

Thanks for the tip!

Finally was able to get the Dev Kit to boot from NVMe by sacrificing Windows 10 from my (semi) old PC and booting Ubuntu 20.04 from it. Certainly not an ideal solution, but at least now I have a Linux computer on hand for all the other robotics tasks that require it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.