Ffmpeg package from nvidia apt repo has missing Replaces package

Hi,

This is not really an error.
But ffmpeg apt package from https://repo.download.nvidia.com/jetson/ffmpeg has one Replaces and Provides package missing: libpostproc-dev.

$ cat /var/lib/apt/lists/repo.download.nvidia.com_jetson_ffmpeg_dists_r36.3_main_binary-arm64_Packages
Package: ffmpeg
Version: 7:4.4.2-nvidia
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 54918
Depends: libaom3 (>= 3.2.0), libasound2 (>= 1.0.16), libass9 (>= 1:0.13.6), libavc1394-0 (>= 0.5.3), libbluray2 (>= 1:0.2.2), libbs2b0, libc6 (>= 2.35), libcaca0 (>= 0.99.beta17-1), libcairo2 (>= 1.2.4), libcdio-cdda2 (>= 10.2+2.0.0), libcdio-paranoia2 (>= 10.2+2.0.0), libchromaprint1 (>= 1.3.2), libcodec2-1.0 (>= 1.0.1), libdav1d5 (>= 0.2.1), libdc1394-25 (>= 2.2.6), libdrm2 (>= 2.4.101), libflite1 (>= 1.4-release-9~), libfontconfig1 (>= 2.12.6), libfreetype6 (>= 2.2.1), libfribidi0 (>= 0.19.2), libgl1, libglib2.0-0 (>= 2.12.0), libgme0 (>= 0.5.5), libgnutls30 (>= 3.7.2), libgsm1 (>= 1.0.18), libiec61883-0 (>= 1.2.0), libjack-jackd2-0 (>= 1.9.10+20150825) | libjack-0.125, liblilv-0-0 (>= 0.14.2~dfsg0), liblzma5 (>= 5.1.1alpha+20120614), libmp3lame0 (>= 3.100), libmysofa1 (>= 0.7~), libopenal1 (>= 1.14), libopenjp2-7 (>= 2.0.0), libopenmpt0 (>= 0.3.0), libopus0 (>= 1.1), libpocketsphinx3 (>= 0.8.0+real5prealpha+1), libpulse0 (>= 0.99.1), librabbitmq4 (>= 0.6.0), libraw1394-11 (>= 2.1.2), librsvg2-2 (>= 2.14.4), librubberband2 (>= 2.0.0), libsdl2-2.0-0 (>= 2.0.12), libshine3 (>= 3.1.0), libsnappy1v5 (>= 1.1.8), libsndio7.0 (>= 1.8.1), libsoxr0 (>= 0.1.0), libspeex1 (>= 1.2~beta3-1), libsphinxbase3 (>= 0.8+5prealpha), libsrt1.4-openssl (>= 1.4.4), libssh-4 (>= 0.8.0), libtheora0 (>= 1.0), libtwolame0 (>= 0.3.10), libvidstab1.1, libvorbis0a (>= 1.1.2), libvorbisenc2 (>= 1.1.2), libvpx7 (>= 1.10.0), libwebp7, libwebpmux3, libx11-6, libx264-163 (>= 2:0.163.3060+git5db6aa6), libx265-199 (>= 3.5), libxcb-shm0, libxcb1, libxext6, libxml2 (>= 2.7.4), libxv1, libxvidcore4 (>= 1.2.2), libzimg2 (>= 0.3.1), libzmq5 (>= 4.0.1+dfsg), libzvbi0 (>= 0.2.35), nvidia-l4t-multimedia, nvidia-l4t-multimedia-utils, ocl-icd-libopencl1 | libopencl1, ocl-icd-libopencl1 (>= 1.0) | libopencl-1.2-1, zlib1g (>= 1:1.2.0.2)
Replaces: ffmpeg (= 7:4.4.2-0ubuntu0.22.04.1), ffmpeg-doc (= 7:4.4.2-0ubuntu0.22.04.1), libavcodec-dev, libavcodec58 (= 7:4.4.2-0ubuntu0.22.04.1), libavdevice-dev, libavdevice58 (= 7:4.4.2-0ubuntu0.22.04.1), libavfilter-dev, libavfilter7 (= 7:4.4.2-0ubuntu0.22.04.1), libavformat-dev, libavformat58 (= 7:4.4.2-0ubuntu0.22.04.1), libavresample-dev, libavresample4 (= 7:4.4.2-0ubuntu0.22.04.1), libavutil-dev, libavutil56 (= 7:4.4.2-0ubuntu0.22.04.1), libpostproc55 (= 7:4.4.2-0ubuntu0.22.04.1), libswresample-dev, libswresample3 (= 7:4.4.2-0ubuntu0.22.04.1), libswscale-dev, libswscale5 (= 7:4.4.2-0ubuntu0.22.04.1)
Provides: ffmpeg (= 7:4.4.2-0ubuntu0.22.04.1), ffmpeg-doc (= 7:4.4.2-0ubuntu0.22.04.1), libavcodec-dev, libavcodec58 (= 7:4.4.2-0ubuntu0.22.04.1), libavdevice-dev, libavdevice58 (= 7:4.4.2-0ubuntu0.22.04.1), libavfilter-dev, libavfilter7 (= 7:4.4.2-0ubuntu0.22.04.1), libavformat-dev, libavformat58 (= 7:4.4.2-0ubuntu0.22.04.1), libavresample-dev, libavresample4 (= 7:4.4.2-0ubuntu0.22.04.1), libavutil-dev, libavutil56 (= 7:4.4.2-0ubuntu0.22.04.1), libpostproc55 (= 7:4.4.2-0ubuntu0.22.04.1), libswresample-dev, libswresample3 (= 7:4.4.2-0ubuntu0.22.04.1), libswscale-dev, libswscale5 (= 7:4.4.2-0ubuntu0.22.04.1)
...

Hi,
Please share more information. It looks like libpostproc-dev may be required if we would like to build ffmpeg from source code. The dependency should not be required if the ffmpeg package is prebuilt?

What I mean is that the package ffmpeg you (nvidia) provide with the apt repository https://repo.download.nvidia.com/jetson/ffmpeg through Linux_for_Tegra/nv_tegra/l4t_deb_packages/nvidia-l4t-apt-source_36.3.0-20240424200557_arm64.deb (installed by apply_binaries.sh in the rootfs, includes ffmpeg binary and runtime files but also dev files. There is only one package in this repo that includes everything (and does not declare libpostproc-dev as Replaces/Provides as I explained in my first post).
This is what I meant.