Fix for NVidia performance issues and stability

Please post if this information was of any use to the performance and/or stability of your system , i assume this is Debian specific

Take note the below might be for my specific hardware ( an aging Dell M4300 with a Quadro FX 360M ) and operating system ( Debian Wheezy ) I’m told most of this is fixed on other distro’s but i noticed similar posts on the forum. Maybe this helps. Do realise i’ve ran into problems with full-screen playback and/or HD playback but not every time.

The benefits i’ve noticed is flash playback is stable ( not 100% but stable ) on 64-bit Linux, graphics performance is without hitches and glitches and does not degrade over time.

[ UPDATE ] This article now has flash working for ALL browsers ( see mms.cfg change below )

Most noteable change with great effect was the below, the … to indicate this is an addition to the existing configuration, do not include them. These options are well documented by NVidia in the Readme.

take note a reboot might not load these settings, power off your system to make sure.

GRUB_CMDLINE_LINUX_DEFAULT=” … nomodeset enable_mtrr_cleanup mtrr_spare_reg_nr=4”

[ update ] noapic was removed, you can add it for testing on your system

first try the above without mtrr_spare_reg_nr=4

enable_mtrr_cleanup is a documented fix for some graphics cards + notebook or desktop bios

I’ve also downloaded and installed the NVidia Long Lived Driver for 64-bit with the below options

./NVIDIA-Linux-x86_64-331.20.run -x
cd NVIDIA-Linux-x86_64-331.20
./nvidia-installer –no-unified-memory –no-install-vdpau-wrapper -N -Z

YOU MUST install with 32-bit compatibility drivers

in addition installing ia32-libs is a good idea, though unverfied to be required

Create /etc/adobe/mms.cfg if does not exist, or make a backup if it does.

Then put the below into this file

UPDATED for fluent flash playback in Iceweasel ( AssetCache and LocalStorageLimit )

#Adobe player settings
AVHardwareDisable = 0
FullScreenDisable = 0
LocalFileReadDisable = 1
FileDownloadDisable = 1
FileUploadDisable = 1
LocalStorageLimit = 5
ThirdPartyStorage = 1
AssetCacheSize = 50
AutoUpdateDisable = 1
LegacyDomainMatching = 0
LocalFileLegacyAction = 0
AllowUserLocalTrust = 0

DisableSockets = 1

OverrideGPUValidation = 1
EnableLinuxHWVideoDecode=1

Change the Device section in /etc/X11/xorg.conf to look like the below

If no such file exists copy the below into a file named /etc/X11/xorg.conf and restart

/etc/X11/xorg.conf

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “NoLogo” ””
Option “RenderAccel” “1”
Option “MigrationHeuristic” “greedy”
Option “TripleBuffer” “true”
EndSection

This is quite specific for my machine but might help you out as well

create or edit /etc/modprobe.d/nvidia-kernel-common.conf to look like below

alias char-major-195* nvidia
options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=44 NVreg_DeviceFileMode=0660
options nvidia NVreg_EnableMSI=1 # optional for a small performance increase
options nvidia NVreg_Mobile=1 # optional for a small performance increase
blacklist nouveau

Don’t use that version, it’s buggy!

Thanks for the warning and the link.

This version works best of the versions i’ve tries, others i’ve tried were those included with Debian. By the way, it’s good to warn or advise someone, but what version would you suggest then ?

So far i’ve not had ANY of the issues mentioned.

Also, look at the last post of that thread https://devtalk.nvidia.com/default/topic/633706/linux/recent-drivers-cause-applications-to-hang-not-start-at-all-or-compilation-failures/2/