Flash AGX Board with only tow dtb files

Hi all
We want to flash our AGX Xavier Board and we use the Jetpack 4.6. We have already installed an SSDnvme,
I am following this link:
Our goal is to enable the PLLAON clock to use the CAN Network. We already modified the kernel DTB and BPMPFW DTB and we want only flash these 2 files on the board.
My questions are:

  • We tried to flash the board with the boot located in eMMC, but nothing happened and the dtb files are not updated. I noticed that there are 2 boot folders: in eMMC and in SSD. So, which one, the board use?
    Also, I checked the boot.config, and I found that is configured to boot from nvme.
    If I have to flash the nvme, how can I do it please?
    Thank you.

hello mokhtar.bouain,

please check /boot/extlinux/extlinux.conf, if there’s FDT entry, it’ll prior to load device tree blob via file system.
since you’ve flashing to the kernel-dtb partition, please remove that entry for loading via partition.

There is no FDT entry.
Please, find the attached file, the used extlinux.conf
extlinux.conf (864 Bytes)

Best regards

hello mokhtar.bouain,

please share your commands to update device tree,
please also setup serial console to check you’ve apply device tree correctly.

Ok, please find in the attached file, the results of the setup serial console.
Also, to flash the board, we use :

sudo ./flash.sh -k bpmp-fw-dtb jetson-xavier mmcblk0p1
sudo ./flash.sh -k bootloader-dtb jetson-xavier mmcblk0p1

uart_Xavier.txt (43.3 KB)


hello mokhtar.bouain,

you should update bpmp-fw-dtb and kernel-dtb.

Hi Jerry,
Can you give us more details about that please? How we do the update?
Thanks you

hello mokhtar.bouain,

here show the steps to update bpmp-fw-dtb

  1. you’ll need to decompile the BPMP DTB to have modification.
  2. recompile BPMP DTB, and copy the new BPMP DTB into… bootloader/t186ref/
  3. perform flash script for partition update… $ sudo ./flash.sh -r -k bpmp-fw-dtb jetson-agx-xavier-devkit mmcblk0p1

for the steps to update kernel-dtb, you may build from kernel sources or decompile/recompile from the target’s binary file.
please copy the new kernel-dtb file into… kernel/dtb/,
and, here’s flash script for partition update… $ sudo ./flash.sh -r -k kernel-dtb jetson-agx-xavier-devkit mmcblk0p1

It works now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.