Flash DTB only on Xavier NX with NVME boot (Jetpack 5.0.2)

I’m trying to boot a Xavier NX from an NVME drive with a custom kernel, and device tree. Everything works fine when booting from EMMC memory, however when using ./tools/kernel_flash/l4t_initrd_flash.sh to flash the jetson, I am not able to flash update just the DTB partition. I would like a simple way to update the device tree only so that our workflow for developing the device tree and kernel modules is similar to using the usual flash.sh tool where we can update just the device tree with sudo ./flash.sh -r -k kernel-dtb -d kernel/dtb/tegra194-p3668-all-p3509-0000.dtb jetson-xavier-nx-devkit-emmc mmcblk0p1
I’ve tried using dd to copy the file bootloader/kernel_tegra194-p3668-0000-p3509-0000.dtb.sb into the partition which the device tree is in, but not had much success. I’ve also tried using the FDT flag in the /boot/extlinux/extlinux.conf file but also not succeeded.

If anyone could share a simple workflow with some steps for updating only the Device Tree partition on a device booting from NVME that would be appreciated.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

I would still like support with this issue if possible.


The readme file should have an example for this. What problem did you hit?

For flashing kernel-dtb partition on external device:
$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh \
  --external-device nvme0n1p1 \
  -c ./tools/kernel_flash/flash_l4t_nvme.xml \
  -k kernel-dtb --external-only jetson-xavier mmcblk0p1

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.