Jetson not using FDT setting in extlinux.conf

I have a Xavier NX setup to boot from NVME with Jetpack 5.0.2. It is flashed using this command:

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1 -c ./tools/kernel_flash/flash_l4t_nvme.xml -S 30GiB --showlogs jetson-xavier-nx-devkit-emmc nvme0n1p1

It works fine and the device tree changes I have made can be found in /proc/device-tree. The problem is that I would like to set the device tree using the FDT option in the file /boot/extlinux/extlinux.conf. however no changes made here seem to do anything.

Here is the content of the file:

TIMEOUT 30
DEFAULT primary

MENU TITLE L4T boot options

LABEL primary
      MENU LABEL primary kernel
      LINUX /boot/Image
      FDT /boot/dtb/kernel_tegra194-p3668-0001-p3509-0000.dtb
      INITRD /boot/initrd
      APPEND ${cbootargs} root=/dev/nvme0n1p1 rw rootwait rootfstype=ext4 console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 

I have also tried to replace the file in /boot/dtb without changing the name, and it also has no impact.

This is annoying to me because I would like to be able to boot from NVME, and modify the device tree without having to flash the jetson.

Any help appreciated.

Please check if you also have another extlinux.conf on emmc. If so, modify that file and see if the result changes.

Thanks Wayne,

It looks like (as usual) you are correct. I didn’t expect this to be the case because I had formatted the emmc before this most recent flash. Are there settings I can change such that the extlinux.conf file from the NVME is used?