Flash Jetson Nano OS stuck at 99.9%

Hi ALL,

I’m trying to flash OS via SDK Manager 0.9.11.3405 but it stuck at 99.9% for hours, is there anyone can help with this? Thanks.

Hi eyonge,

It’s weird!
Can you close SDKM and run again? before run SDKM, please put your device into recovery mode again. Thanks!

OK, it turns out to be the Virtualbox issue. I run SDKM on Ubuntu 16.04 in a Virtualbox virtual machine. When I switch it to a VMware machine, the issue gone.

Hello.
This continues to happen with latest NVIDIA SdkManager 0.9.13.4753, JetPack 4.2.1 and both NANO and Xavier.
Install slows down at “Flash Jetson OS” step closer it gets to 99%, between 99.6 and 99.7% stayed for 15 minutes, then stays for half an hour at 99.7%…

In the terminal nothing is changing:
tegrarcm --chip 0x21 0 --updatesig rcm_list_signed.xml

What is the correct thing to do?
If I stop SdkManager it will start “Flash Jetson OS” again from zero.

I am using VBox with Ubuntu 18.04.

Hi, please note VirtualBox is not compatible with SdkManager, please use Vmware workstation player instead.

I was able to reproduce it with VMware® Workstation 14 Player.

SdkManager reported some errors in the terminal but install anyway continues, progress slows near 99%, until again stops completely at 99.9%, after about 2 hours. The only way the user can see that something is wrong is that messages in the Terminal is not changing for a lot of time and the warning message popup that eventually appears. I finally installed the “Flash Jetson OS” with script and the rest packages through the Ethernet.

Nvidia - please fix the SdkManager progress problem.

Another flaw I see for the Nano & Xavier flashing is that there is no indication that device is really in Recovery mode. Would be good atleast to have a status indication in the manager.

No VM is supported. To make any VM work you need to make sure any USB or ethernet used in an operation is 100% owned by the VM and not the host PC. A regular host handles this correctly, but default VM configs tend to become confused by USB repeatedly disconnecting and reconnecting (which is normal operation).

No VM is supported.

THIS IS UNACCEPTABLE. Full stop. Do you even remotely understand who your customers are? “Um, sure, I’ll just run Linux natively in my locked-down corporate IT environment.” No. The sdkmanager MUST work with both VMWare and VirtualBox VMs, or it is USELESS.

3 Likes

VMs do not have valid USB pass through unless you know how to set up the VM. The flash software does not care about a VM, but using a VM not set up correctly is not the fault of the flash software.

What it comes down to is that you can use a VM, but no official docs exist on how to do that since a VM tutorial is beyond the scope of flashing the system. To emphasize, the problem is that as USB disconnects and reconnects, then by default a VM redirects USB to the host and not the guest o/s…flash software has no control over that. Even if information were added in support of a VM there are several brands of VM and all of them are configured differently.

You’ll need to find out how to dedicate that USB device such that the guest o/s always gets control of the device.

1 Like

You’ll need to find out how to dedicate that USB device such that the guest o/s always gets control of the device.

If this were correct, I wouldn’t be so angry for wasting two days trying to make sdkmanager work with an Ubuntu 18.04 VirtualBox VM. But your statement is simply not accurate. I’ve added these two USB filters in VirtualBox:

and it still hangs 99.7% through the ‘Flash Jetson OS’ step, exactly as the OP described. What more can I do?

The only suggestion I have is that several people have posted how they got their VM to work. The same methods work for Nano, Xavier, TX2, TX1, and TK1. Although the flash software itself is different on each type of Jetson, the VM information will still apply. I would Google for VM topics on devtalk.nvidia.com and go through those. There will be a lot of frustration going through so much information, but when you find tips from one person about how this was solved there is a good chance this will solve your issue as well (which is why nobody officially supports a VM…the frustration on the developer side is that we know the flash software works, but a VM gets in the way…and every VM is different in how it fails).

I was also initially trying to set up a Jetson Nano (via the USB cable using the SDK Manager, which was running on a Linux PC. Indeed, the process became stuck at 99.9% for hours and hours. Frustrating!

Turned out the I had incorrectly selected ‘Jetson Nano’ as Target Hardware instead of ‘Jetson Nano (Developer Kit Version)’. After making the right choice everything installed properly except the Computer Vision component. I’m still trying to figure that part out…

Good catch…most modules are the same and only carrier boards differ, but the Nano dev module is different from the Nano production module. Little things like that will cause it to hang.

I have now figured the ‘Computer Vision’ component not installing issue:

In the sdkmanager program’s Step 01 (Developement Environment), Hardware Configuration, I had not unchecked ‘Host Machine’. The program was presumably trying to install ‘Computer Vision’ component on the Linux PC which was running the sdkmanager program instead of the Jetson Nano.

All in all the sdkmanager is simply not friendly enough for someone ‘new’ to the program. Given the the super low cost ($99) Jetson Nano board is such great value, and will therefore attract lots of AI novices (likely running on Windows Laptops), NVIDIA could do worse than provide a step-by-step installation guide (or better still a Youtube video).

Anyway, the SD card is fully loaded now and my Nano is up and running; on to the rest of the adventure.

1 Like

The trouble I had installing the ‘Computer Vision component’ on the PC controlling the Jetson Nano turned out to be the PC’s non-Nvidia GPU. The ‘Computer Vision component’ requires an Nvida GPU chip!

Hi folks, I am seeing the same stalling problem with a Nano Dev Kit. When using the sdkmanager I can’t get past 99.9%. I am using a dedicated PC with Ubuntu 18.04.3 LTS installed (i.e. physical host, no virtualbox, no vmware).

Watching the ~/.nvsdm/sdkm.log it appears to get to “Saved platform info in storage_info.bin” and no further. I have tried 3 different USB cables and two different JetPacks (4.3 and 4.2), two SD cards and a multitude of power sources and the same thing happens in all cases.

If I follow the L4T quickstart guide and run the “./flash.sh jetson-nano-qspi-sd mmcblk0p1” I see the same effect in the log (i.e. stops at “Saved platform info in storage_info.bin”).

Any hints appreciated!

Getting stuck at 99.9% was, for me, related to installing the ‘Computer Vision component’ on the PC controlling the Jetson Nano. Turned out to be the PC’s non-Nvidia GPU. The ‘Computer Vision component’ requires an Nvida GPU chip in the controlling PC!

Yep, thanks for that hint, I have already unticked the host installation in the sdkmanager.

According to the sdkm.log file mine is stalling during or immediately after the “tegradevflash … --oem platformdetails storage storage_info.bin” command is executed. This actually happens way before the progress bar reaches 99.9% so the progress bar can lead you to think that the installation is nearly finishing when infact it is failing (for me at least) around 57%.

Is there any way to enable additional debugging for the tegradevflash executable?

You need to select USB 3.0 (xHCI) Controller if using VirtualBox.
USB 2.0 seems to work if your host machine is running Windows.

This was tested on VirtualBox 6.1 running Ubuntu 18, SDK Manager 1.2.0.6738, JetPack 4.4, Jetson Nano P3448-0002.

Cheers!

(This is for WSL2 users on windows 10)
I had same issue, but i solved it.
My environment is Ubuntu by WSL2 on Windows 10.
WSL2 do not support USB yet, so sdkmanager could not detect Xavier.
I borrowed ubuntu host computer, so issue was gone.