Flashing basic flavored rootfs


I have been experimenting with building a rootfs using the nv_build_samplefs.sh script.


./tools/samplefs/nv_build_samplefs.sh --abi aarch64 --distro ubuntu --flavor minimal --version focal

and than flashing my Jatson Orin Nano devkit with

sudo ROOTFS_AB=1 ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_nvme_rootfs_ab.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 jetson-orin-nano-devkit internal

Worked fine.

I than build a rootfs using the basic flavor:

./tools/samplefs/nv_build_samplefs.sh --abi aarch64 --distro ubuntu --flavor basic --version focal

If I use the mentioned flash command to flash my basic flavored rootfs, I get the error:

cp: cannot stat ‘(…)/rootfs/usr/sbin/flash_erase’: No such file or directory

I found out that flash_erase is part of mtd-utils, which is not included in nvubuntu-focal-basic-aarch64-packages.

Is there another way to flash my device when using the basic flavored rootfs?

Any help is highly appriciated.


it looks like a bug, and we’ll be checking it.
I think you can just manually add mtd-utils back to nvubuntu-focal-basic-aarch64-packages.

Thanks for the response.

I have an additional questions
Is there a way to download the minimal flavored rootfs without having to build it myself?
How much do these rootfs change with other Jatpack Versions?

Any help is highly appriciated.


I think for the pre-built rootfs, we only provide the desktop flavor.
You have to build it yourself if you want to use the minimal or the basic flavor.


we have fixed it internally, and it should be reflected in future release of L4T.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.