Flashing Redundant Rootfs on NVMe SSD Orin

I have used the following command to flash a standard rootfs to an Orin Devkit on a M.2 NVMe SSD:

$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh -c tools/kernel_flash/flash_l4t_external.xml --external-device nvme0n1p1 jetson-agx-orin-devkit external

This works as expected.

I then tried the command to flash a redundant rootfs on the emmc:

$ sudo ROOTFS_AB=1 ROOTFS_RETRY_COUNT_MAX=1 ./flash.sh jetson-agx-orin-devkit mmcblk0p1

This too works as expected and I am able to switch between the two.

Now I am attempting to flash a redundant rootfs on the SSD in the same manner. I have tried this command:

$ sudo ROOTFS_AB=1 ROOTFS_RETRY_COUNT_MAX=1 ./tools/kernel_flash/l4t_initrd_flash.sh -c flash_l4t_nvme_rootfs_ab.xml --external-device nvme0n1p1 jetson-agx-orin-devkit external

However I am unable to boot after the flashing completes.

Is this the right command and xml config?

I have the boot logs, but I ran out of characters so if you need those I can provide.

Please provide the full log here.

I had to link the logs due to the character limit:

Host machine: Host Log - Pastebin.com
Target orin: Target Log - Pastebin.com


can you please attach the log as text files here?
I cannot access Pastebin due to some firewall settings.

host.log (369.0 KB)
target.log (56.0 KB)


so clearly even the flashing process itself was not successful:

[ 213]: l4t_flash_from_kernel: Successfully flash the qspi
[ 213]: l4t_flash_from_kernel: Flashing success
Error flashing non-qspi storage

Can you try again and record the serial console log during flashing?
Your log now looks to be captured after flashing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.