Can't flash a working NVMe SSD on Jetson Orin AGX

I’ve been trying to flash a 1Tb NVMe drive as a boot drive on my Jetson Orin AGX, without success. Here is the background:

  1. I’ve successfully installed the SSD as an external drive on the Jetson, using the Ubuntu Disks utility. I’ve tried doing both a quick ext4 format, and a “full” one where I erase the existing data.

  2. As an external drive, I can mount it, copy folders and files with no errors. It also benchmarks ok, again using the Disks utility.

  3. Using the SDK Manager on a Ubuntu 22.04 x86 desktop connected to the USB-C port beside the GPIO, I can flash the eMMC card without a problem. I use the automatic installation version and pre-config.

  4. Doing the same steps as (3), but just changing eMMC for NVMe, I can’t get it to flash. Some of the errors are shown in the screen shots below.

  5. The Jetson will not boot from the NVMe even if I set it manually using the Boot Options.

  6. Booting from the eMMC shows that the NVMe drive hasn’t been touched. Any test files or folders I copied before the flash attempt are still there.

  7. I’ve tried just flashing and not installing the runtime or SDK components. Same result.

  8. I’ve tried having a monitor connecting to the Jetson during the flash, and also tried with the monitor switched off. Same result.

  9. I’ve tried having setting the SSD to auto mount on the original eMMC. I’ve tried it without too. Same result.

Looking at the logs, and given that nothing gets erased from the drive, my guess is that the SDK Manager simply can’t write to it.

Any guesses anybody? I’m tearing what’s left of my hair out!!

These are the very first errors:

Here are the SDK Manager and minicom logs:
SDKM_logs_2024-02-28_14-54-57.zip (497.2 KB)
minicom.cap.txt (81.0 KB)

Instead of “more & more and more”, there is a “EXPORT LOGS” button on your sdkmanager… you can dump the text log instead of screenshot…

1 Like

You’re right - thanks. I was trying to copy and paste the logs from the SDK manager. I’ve now uploaded them to the post above.

Do you have any suggestions about the question itself?

  1. I remember the full log should be a zip file instead of text file only. Could you double check?

  2. Please also dump the serial console log from device during the flash process.

I’ve uploaded the full zip file. How do I do I get the serial console log from the Jetson?

If you are using Orin AGX developer kit, then you can use this.

If you are using custom board, then need to check with board vendor.

Also, you may need to dump the log again because host side and device side log are pair.

It is not a good idea to check a host log that was dumped 30 mins ago while the device log is new one.

I’m not using a custom board, it’s the Jetson Orin AGX dev kit 64Gb.

I’ve installed minicom on the host as per the instructions you linked to. How can I find out which port the Jetson is connected to on the host? The instructions say /dev/ttyACM0, but all I have are /dev/tty** and /dev/ttyS** entries.

Are you using the micro usb port or type C port on Jetson board?

type C. The one just by the GPIO.

I mean the one you are using to dump log. Not the one you are using for flashing.

Oh, I see. Thanks. After connecting a second USB cable from host to the Jetson’s micro USB port, I managed to capture ttyACM0. Both logs are now uploaded on the original post.

Hi,

It seems not related to NVMe. But the NFS server mount failure. Only initrd flash will use this but flash.sh won’t. That is why you didn’t hit issue when flashing emmc.

TNETLINK answers: File exists
Waiting for device to expose ssh …Run command: flash on fc00:1:1:0::2
SSH ready
mount.nfs: Connection timed out
Flash failure
Cleaning up…
14:54:01.903 - Error: [exec_command]: /bin/bash -c /tmp/tmp_NV_L4T_FLASH_JETSON_LINUX_COMP.simon.sh; [error]: 128412 blocks

The issue could be from host side setting.

1 Like

Excellent, I would never have guessed this. Thanks.

For those who have Ubuntu 22.04, the way to disable the firewall is

sudo ufo disable

I have now successfully flashed the NVMe. I have come across another issue, but I’ll try to resolve that myself, and if not, open another topic.

Thanks again, Wayne.

1 Like

Sure. Please remember to dump serial log if you want to file new topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.