Flipping working selectively for some games only

I’ve reported the same issue to Cinnamon but I’m posting it here too bc I was told that this might be a driver issue.

 Cinnamon 5.4.12, Arch Linux 64-bit, GTX 1660 Ti, 515.57.

Issue
Flipping is working for some games only

Steps to reproduce

  1. Download game named Cradle, it’s on Steam and it’s available for Linux natively.
  2. Create a profile in local nvidia-settings to display OSD (the thing that shows FPS), it’s called “GLShowGraphicsOSD”. You might have to run the game once to see the process name and then add it to the nvidia-settings profile, so that when nvidia-settings finds this process, it will display the OSD along with FPS and other info.
  3. Run the game and observe the top left corner - it will read “FLIP - VSYNC ON” all in green text which means Flipping is working.
  4. Now do the same (process name set to eurotrucks2) for Euro Truck Simulator 2 (also on Steam and also available for linux natively), then run the game. This time you’ll see “BLIT - VSYNC ON” with “BLIT” being written in red color.
  5. Metro 2033 (another native game) also has the “BLIT” which means flipping isn’t working.
  6. Half Life 2 (also native) sometimes flipping is working, sometimes it isn’t.

Expected behaviour
Flipping should be working for all games.

Other information

  1. All the necessary settings in xorg.conf for flipping to work have been made:

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “NVIDIA GeForce GTX 1660 Ti”
Option “NoFlip” “false”
EndSection

  1. I use only drivers whose versions are two groups of digits - 465.31, 515.57 and so on, so don’t offer me the latest driver whose version is like this: XXX.XX.XX.