GeForce 340.108 + Linux X64 Outdated

Hi, I’m using arch linux, would you please update the driver because it’s hard to get my money back.

The driver is working for linux-kernel-5.4.xx-lts but is not working for for linux-kernel-5.10.xx-lts. It would be nice to update the driver. It’s nvidia issue, it’s not linux issue.

I’m currently using HP Pavilion dv7-3110sv notebook and GPU GeForce G 105M.

I spoke with HP community and they told me there is nothing I can do to improve the graphics in my notebook.

Which means I can’t stay forever on linux-kernel-5.4.xx, one day I’ll have to upgrade the linux-kernel.

Please give me a solution.
nvidia-installer.log (36.8 KB)

Support timeframes for Unix legacy GPU releases. Nvidia dropped support for your GPU at the end of 2019. They won’t be updating the driver. You can try Nouveau. There is an Ubuntu PPA where someone is trying to patch it: ppa:kelebek333/nvidia-legacy. You can try grabbing the patches from that.

Hard times you know that very well.
Please convince them to continue to update the driver and opengl version as well.

The driver must be updating together with the rest of the system.

I’m just an end user like you. I have no influence. There are hardware limitations that will prevent them from supporting a higher OpenGL version on that GPU. It is 13 years old.

OK, keep the same version of OpenGL. If you are user like me, then who is incharge here? Tell him I’m thinking out to send my laptop in high school in 2 years. The laptop is fine the driver is the problem.

Also I tried to fix the screen tearing bug, but I still have it.
Who’s gonna fix it?

Run In terminal:
$ nvidia-settings --assign CurrentMetaMode=“nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }”

Get Screen Resolution
$ xrandr

Edit the xorg.conf file
$ sudo nano /etc/X11/xorg.conf

Depends on Screen Resolution
Run In terminal:
$ nvidia-settings --assign CurrentMetaMode=“1600x900_60 +0+0 { ForceFullCompositionPipeline = On }”

Section “Screen”
Option “metamodes” “nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}”
Option “metamodes” “1600x900_60 +0+0 {ForceFullCompositionPipeline=On}”
Option “AllowIndirectGLXProtocol” “off”
Option “TripleBuffer” “on”

But the nvidia-settings > X Server Display Configuration > Save to X Configuration File > Show preview

Section “Screen”

Removed Option “metamodes” “1600x900_60 +0+0 {ForceFullCompositionPipeline=On}”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "AllowIndirectGLXProtocol" "off"
Option         "TripleBuffer" "on"
Option         "Stereo" "0"
Option         "metamodes" "1600x900_60 +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24


Doesn’t accept this Option “metamodes” “1600x900_60 +0+0 {ForceFullCompositionPipeline=On}”