Geforce 820M problem on many linux distros

Good day all!
I have problem on graphic card Geforce 820M at many linux distros.
For example, at ubuntu 14.04 LTS, in Additional drivers, proprietary driver is 340.96. If I choose it, after reboot there is common problem, black screen. All right. I’m not trying this method again.
After that I removed nvidia driver with purge command and try find in internet solution. Some people says, that for 820M need 346 driver. I tried is and result was same, black screen. Again used purge command.
Next was try to use Nvidias official drivers, from nvidia.com. I Try 361.42 .run driver. Before install it, I blacklisted nouveau driver and after this on level 3 lightdm (sudo /etc/init.d/lightdm stop) I tried install this driver. After install I use sudo nvidia-xconfig command, but when ubuntu finished boot, there cann’t be log in system. When I entered password, it backs me login window again and again. Again removed nvidia driver with bash command and tried install 340.96.run driver. Result was same.
This problem is not only at ubuntu. I tried other debian based linux distros and all of them with this problems.
I’m dual booting with Windows 10 and in Windows, Nvidia’s graphics card works super fine.
My laptop is Dell Inspiron 15 3542 with hybrid graphics card. I think that reason of this problem is hybrid graphics and is there any chance to use Nvidia’s graphics card on my laptop at any linux distros? Bumblebee aslo this result and I’m not very keen of bumble.

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

08:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)

Wish you success all Nvidia users. Good luck!

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1507676
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1501041
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1419507

Possible workaround: just close the lid of your laptop? wait for suspend, open again

Possible solution: https://vxlabs.com/2015/02/05/solving-the-ubuntu-14-04-nvidia-346-nvidia-prime-black-screen-issue/

araknafobia, I could be wrong, it is OK on 16.04 and 15.10 due to modesetting driver in xorg.conf.
There were workaround in ubuntu-drivers-common package, but seems it was not been released for 14.04

I think that problem is in ubuntu 14.04 LTS, because I installed ubuntu 15.10 at my laptop and it works pretty. At 14.04 LTS Graphics was Intel Haswell and now at 15.10 Graphics is GeForce 820M/PCIe/SSE2.
It still has problem, video is not syncronized, but now it using Geforce graphics.
Thanks all for answer.