GeForce GT 755M does not seem to support CUDA

Hello All,

I have a GeForce GT 755M GPU. While the product description of the GPU mentions the support of CUDA (http://www.geforce.com/hardware/notebook-gpus/geforce-gt-755m/features). But, the make of the GPU is not mentioned here ->https://developer.nvidia.com/cuda-gpus. The information is completely different from that of the product specs.

Also, I tried installing the NVIDIA Tool Ver 6.5 onto my Laptop, the toolkit was installed. However, when I compile the CUDA samples and run the deviceQuery sample, I get the following output


./deviceQuery
./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL


I am using Ubuntu 14.04 64 bit OS with NVIDIA driver version 346. I need to use my laptop for CUDA programming, any help will be appreciated.

I used this particular blog (http://www.quantstart.com/articles/Installing-Nvidia-CUDA-on-Ubuntu-14-04-for-Linux-GPU-Computing) for installation of CUDA toolkit and SDK

Thank You

GeForce 755M indeed supports CUDA. I followed instructions to instal CUDA toolkit from here - http://www.quantstart.com/articles/Installing-Nvidia-CUDA-on-Ubuntu-14-04-for-Linux-GPU-Computing
It"s just that before running deviceQuery, issue the following command:

sudo nvidia-xconfig --enable-all-gpus

I am also having trouble getting CUDA to work with my card (a GTX 750 Ti) on Ubuntu 14.04. After reading your post, I ran

sudo  nvidia-xconfig -t

and got back

Unable to locate/open XConfig file.

suggesting that I do not have an X config file.
Your recommendation to run

sudo  nvidia-xconfig -enable-all-gpus

is the first reference I’ve come across to the need to “enable” GPUs for CUDA. Do you happen to have a link or explanation of why this is needed? I’m hesitant to run a sudo command which has the potential to cause problems with my video.