CUDA on GTX 750 TI?

Hi all,

I just got a cool new GTX 750 TI and am trying to get CUDA working for it on Ubuntu 12.04.
I can’t seem to get my machine (or the developer tools) to recognize the card. Our machine additionally has a Tesla K20c.

I installed the latest CUDA (5.5.22) after I plugged in the chip.

When I run “lspci | grep “NVIDIA”” I see:

02:00.0 3D controller: NVIDIA Corporation GK110GL [Tesla K20c] (rev a1)
03:00.0 VGA compatible controller: NVIDIA Corporation Device 1380 (rev a2)
03:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)

and “nvidia-smi” shows:

Wed Feb 26 21:55:12 2014       
+------------------------------------------------------+                       
| NVIDIA-SMI 5.319.37   Driver Version: 319.37         |                       
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  Tesla K20c          Off  | 0000:02:00.0     Off |                    0 |
| 31%   42C    P0    43W / 225W |       11MB /  4799MB |     99%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Compute processes:                                               GPU Memory |
|  GPU       PID  Process name                                     Usage      |
|=============================================================================|
|  No running compute processes found                                         |
+-----------------------------------------------------------------------------+

Is this chip not supported on Ubuntu 12.04? It’s listed on the CUDA GPUs page:

Thanks in advance, let me know if I need to post more info

The GTX 750 Ti is not supported by the driver (319.37) that is included with the cuda 5.5 toolkit installer package. Download the latest driver installer package for GeForce 750 Ti from www.nvidia.com and run that to replace your 319.37 driver (only). You should have better results. Yes, CUDA 5.5 is compatible with the newer driver you are installing.

Ah, I see. I noticed I couldn’t find the driver directly from inside the NVIDIA site. That is, when searching for drivers via the driver finder, it reports no available drivers for GTX 750 TI Ubuntu 64.

Instead I did a google search for “NVIDIA 334.16 Beta driver” and found the link.

Thanks, It’s up and running now!

the nvidia-331 driver (331.20) from the x-swat and x-edgers ppa’s also worked for me, although it does not yet show the 750 Ti cards under their proper product names yet (it uses a cryptic code name instead).

Christian

Will the GTX 750 Ti work with CUDA 6?

Yes, it will. I would recommend using the 334.21 driver that was just published:
http://www.nvidia.com/download/driverResults.aspx/73666/en-us

with the CUDA 6RC release

When CUDA 6 is formally released, the driver in it will be fine too.

Thanks for the reply!

Hi, I was always (last 4+ years) able to run latest fedora with proprietary nvidia drivers and cuda support, but I failed this time :(
system somehow runs now with

vmlinuz-3.13.9-200.fc20.x86_64 nomodeset rd.driver.blacklist=nouveau rd.driver.blacklist=i915 video=vesa:off nouveau.modeset=0 drm.modeset=0 video.allow_duplicates=1

but although cuda works partially, (latest 337beta) nvidia display driver cannot be used for X,
please see here : https://gist.github.com/10271994
any help appreciated