NVIDIA GeForce GTX 750 Ti Troubles

I’ve recently bought a 750 Ti but am having a lot of difficulty getting it working with Ubuntu.

I read in another recent thread to try the 334 beta drivers but am not having much luck. At the moment when I try to start X server it hangs when trying to load the extension XINERAMA.

I’ve also noticed that the 750 isn’t listed as being supported. Anything else I can try?

Install the drivers, try to load X, upload your nvidia bug report.

Were you able to get it to work?

GTX 750Ti is now supported in the latest stable branch 334.21.

NVidia Maxwell 750 Ti install failed for SL6.5

Working configuration
NVidia Quadro 1800 FX in PCIex16_1 (blue socket) with one LCD via DisplayPort and another via DVI-D port
OS: scientific linux 6.5-i686/x86_64
Motherboard: Asus-M4A79-Deluxe <-- recommends to install two GPUs into two blue PCIex16 slots

New GPU-card
MSI GTX 750 Ti Gaming 2GB >> http://www.techpowerup.com/reviews/MSI/GTX_750_Ti_Gaming/
Dual Link DVI-D, VGA, HDMI <-- nb: ** no DisplayPort, only one DVI-D port **
installation trials both in PCIex16_1 (blue socket) and PCIex16_2 (blue socket)
one GPU installation trials in PCIex16_1
dual GPU installation trials with Quadro 1800 FX both in PCIex16_1 and PCIex16_2
software drivers from MSI CD could not be installed because of Linux kernel panic/fatal exception

Current non-working configuration
Quadro 1800 FX installed in PCIex16_1 (blue socket) with one LCD via DisplayPort and another via DVI-D port
OK serving one LCD via DisplayPort and another via DVI-D port
MSI-GeForce-GTX-750-Ti-Gaming in PCIex16_2 (blue socket), no monitors connected
OS: scientific linux 6.5-i686/x86_64 with old GPU-drivers

Example 1 : failed DVD Boot
right monitor connected via DVI-D to MSI-GeForce-GTX-750-Ti-Gaming card
Sci-Linux seemed to detect existing hardware and software
left monitor dark - connected via DisplayPort to NVidia Quadro 1800 FX in PCIex16_2 (blue)
running /sbin/loader
detecting hardware <-- *** dies(tilts) here ***

Example 2: booting from hard disk and DVD with only new GPU
*** nouveau E[ PMC unknown interrupt ] ***

Example 3: Quadro 1800 FX in PCIex16_1 serving both displays, 750-Ti in PCIex16_2 without display

both screen show Linux start <=> Quadro 1800 FX works as before!
Linux kernel in panic! => Linux did not start => unable to continue and therefore unable to update GPU-drivers

BUG: unable to handle kernel NULL pointer
IP: [xxxxxxxx] nouveau_pm_fini +0x37x10x160 {nouveau]
PGD 0
Ooops: 0000[#1] SMP
last sysfile: /sys/devices/virtual/block/ramb/queue/scheduler
Modules linked in: nouveau(+) ttm drm_kms_helper drm i2c_algo_bit i2c_com mxm_wmi video outpu wmi ipv6 iscsi_ibft
Pid 355 work_for_cpu Not tainted 2.6.32-358.c16.x86
System Manufacturer Sys Prod / M4A79 Deluxe
Call Trace
[xxxxxxxx] nouveau_card_init + 0x145f / 0x1868 [nouveau}
Kernel panic - not syncing - Fatal exception

Question 1: How to upgrade software drivers for MSI-GeForce-GTX-750-Ti-Gaming ?
note: Linux dies i.e. does not start ok to allow updating drivers!

Question 2: Do I have to reintall Linux ?

Question 3: Do I have to
a) first boot just with Quadro 1800 FX
b) update drivers ready for MSI-GeForce-GTX-750-Ti-Gaming >> http://www.nvidia.com/download/driverResults.aspx/73666/en-us
c) install MSI-GeForce-GTX-750-Ti-Gaming
d) boot from hard disk

Question 4: Other Options to get both GPUs to work ?

The reason why you can’t just boot a Live CD with that card is because there is no out-of-the-box support for it through nouveau. nouveau is a reverse engineered open source nvidia driver developed by independent developers that ships with any Live CD. In the past few months NVIDIA has helped them out with GPU documentation, but it will probably take some time until they implement support for the new Maxwell cards in nouveau.

So to use your card you have to boot with “nomodeset” as kernel linux parameter in your bootloader. That should get you far enough so you can install the “proper” driver. You could also switch to a tty and download the driver with wget/curl and install it from there. After that you’ll be able to boot into your normal desktop.

THANKS !

The following (and previous) actions were performed by booting from hard disk,
where the scientific Linux was installed and working fine before this new GPU-card:

Step 1/33) booted Scientific

Step 2/33) pressed SHIFT key

Step 3/33) got
GNU GRUB version 0.97
Linux (2.6.32-431.5.1.e16.x86_64)

Step 4/33) selected e = edit

Step 5/33) selected kernel
Step 6/33) edited <root rhgb quiet <-- splash nomodeset
where
a) ** splash seemed to prevent opening virtual terminal which was used to install NVidia driver
b) nomodeset ok

Step 7/33) sci-linux booted ok

Step 8/33) downloaded NVIDIA-Linux-x86_64-334.21.run

Step 9/33) met several problems due to splash

Step 10/33) repeated 1 - 5

Step 11/33) edited <root rhgb quiet <-- nomodeset

Step 12/33) sci-linux booted ok

Step 14/33) started command mode

Step 15/33) telinit 3

Step 16/33) ./NVIDIA-Linux-x86_64-334.21.run

Step 17/33) yes to “Install NVIDIA’s 32-bit compability libraries?”

Step 18/33) selected “run nvidia-xconfig utility to automatically update x config file”

Step 19/33) saw “Installation of NVIDIA Acceleated Graphics Drives for Linux_x86_64 (version: 334.21) is now complete”

Step 20/33) reset

Step 21/33) booted and forgot to press SHIFT

Step 22/33) saw only ** nouveau E uknown intr ** in both screens

Step 23/33) reset

Step 24/33) boot with SHIFT

Step 25/33) edited <root rhgb quiet <-- nomodeset

Step 26/33) verified NVIDAI X Server Settings
a) GPU 0 - (Quadro FX 1800) <-- Samsung Syncmaster DFP-1 and DFP-1 connected ok
b) GPU 1 - (GeForce GTX 750 Ti) <–no displays i.e. OK because acting as GPU computing platform
+ no conflicts in interrupt levels
+ no conflicts in PCI-bus addresses

Step 27/33) open & to be done permanently until nouveau drivers will be available: <root rhgb quiet nomodeset
question 1: how, what is the safest (not necessary coolest) way to proceed - ideas welcome!

Step 28/33) open & to be done: install OpenCL for these cards
question 2: how, what is the safest (not necessary coolest) way to proceed - ideas welcome!

Step 29/33) open & to be done: install CUDA for these cards
question 3: how, what is the safest (not necessary coolest) way to proceed - ideas welcome!

Step 30/33) open & to be done: how to open a new topic in https://devtalk.nvidia.com/ ?
problem: how to create topic headers when
a) one does NOT get any header prompts!
b) not even my fellow guys see there any field to be fille because of black & green screen!

Step 33/33) learned so far (in hard way):
a) ** “designed to fit-products” are hard to find - check how well/whether a new GPU-card will fit inside the chassis!
b) ** too many power on/off may brake something - one USB-disk already lost in this process!
c) ** one process with interrupt problems serving a GPU may halt the whole Linux!
~ one would expect OS to kill the process and proceed instead of having “kernel in panic”!
d) ** reliable would serve better than cool specially in the boot process to get OS booted ok!
~ unreliable GPU drivers in kernel should handle exceptions!
e) ** “business as usual” with a new GPU-card
~ delivery late from dealer, suppor-CD only for Windows, bugs in software such as OpenCL/CUDA, no kernel drivers …!
f) ** only Windows support from dealers
g) ++ GOOD Linux community support - THANKS GUYS! ++

It looks like it still wants to load the nouveau kernel module. Usually the package for your distro does that, but you’re doing a manual install. Try blacklisting the nouveau kernel module. You’ll have to look it up how to do that with Scientifc Linux.

Did you have any success getting it to work finally?

thanks for checking!

status: not yet!
blacklisting not yet tried, because it looks like blacklisting has not worked for many of those having tried it

challenges: hit another problem trying to fdisk 4TB hard disk for using as work/array/matrix/… space for GPU computing
- looks like fdisk is 32-bit and therefore capable to handle <2TB disk
- unrsolved which 64-bit software to use for partitioning (gdisk… and file format (gfs2…)

continuation with this challenge: trying to find out/get help/explore:

  1. why installing NVidia drivers loaded from NVIDIA site and installing OK are not taken into use by Linux ?
    a) what is missing ?
    b) why does NVidia tell everything ok & installed although next time you boot that’s not the case ?
    c) are NVIDAI/Linux installation programs designed only for one GPU card i.e. they don’t notice other NVIDIA cards in system ?
    d) taking into account NVIDIA FX 1800 used noueavau derivers blacklisting them would stop/halt NVidia fx 1800 and displays ?
    e) is the solution to manually define nomodeset in boot until noueavau drivers will be available for gtx 750 Ti ?

  2. is dual NVIDIA 750 Ti as GPU-card and FX 1800 as graphics card too difficult to Linux and NVidia ?
    a) why does system decide to apply noueavau drivers to both GPU cards ?

  3. is it wise/safe to edit a boot/config file manually to make boot work or to avoid risks and go for option 1e) ?

  4. would installing CUDA software help ?

  5. Would installing OPENCL software help ?

  6. using option 1)e until well tested procedures become available ?

It will simply never work aslong as nouveau is not blacklisted. Even if it doesn’t solve the problem right away you’ll have to do it anyway. The system is just doing it’s job when loading nouveau.

ftp://download.nvidia.com/XFree86/Linux-x86/256.44/README/commonproblems.html

See Section 8.1

Hi, I was always (last 4+ years) able to run latest fedora with proprietary nvidia drivers and cuda support, but I failed this time :(
system somehow runs now with

vmlinuz-3.13.9-200.fc20.x86_64 nomodeset rd.driver.blacklist=nouveau rd.driver.blacklist=i915 video=vesa:off nouveau.modeset=0 drm.modeset=0 video.allow_duplicates=1

but although cuda works partially, (latest 337beta) nvidia display driver cannot be used fo X
please see here : https://gist.github.com/10271994
any help appreciated

Any luck with it so far?

no progress,problem is even worse now, because I followed advice and installed driver from rpmfusion. System freezes now at the same point as with 337beta (see https://gist.github.com/10505153 ) even without vga=normal and with ‘3’ kernel parameter :(

I would guess the problem is latest motherboard (Z87) with latest Intel (i5-4670) with latest GPU (750ti).
I had to blacklist i915 driver as well, otherwise system freezes (or just graphics display, numlock was responsive, ALT+SysRq+REISUB worked).
Any advice how to debug - or whom to contact at nvidia is appreciated.

Even at run level 3? That seems odd… I have no experience with integrated graphic processors but it sounds like it might be related. I don’t think the LGA 1150 platform per se is the problem, it’s a very common platform by now. So far I heard only from older AMD platforms being incompatible with the latest Maxwell GPU.

I’d like to add that the system was working with Fedora 20 and integrated intel GPU before inserting 750ti well.
And it works with 750ti and windows 8.1 preview I had found somewhere.
Results here : http://uloz.to/x2rHbMwJ/cuda6rc-win81-results-zip
Please help me to debug that beast or whom shall I ask for help ?
Thanks a lot.

small update. it works flawlessly with ubuntu10.04 kernel 2.6.32-51.
With Fedora 16 kernel 3.6 screen display does not update after “unified memory driver 100%” but computer is accessible through ssh - and after successfully installing nvidia driver through ssh, I am not able to boot anymore.
booting freezes with ubuntu13.10 kernel 3.11 and Fedora 20 kernel 3.13.
I do not want to be greedy ;) but I’d love to have my fedora 20 working with cuda …

Fedora 20 (3.13.9) is working totally fine with a GTX 750 Ti on my side…

System is running fine for more than a week now. Fedora 20, Gigabyte H87-HD3, Intel i5-4670

workaround : update BIOS to F6 and disable intel GPU in BIOS

present kernel 3.13.10-200.fc20.x86_64 line :
ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 vconsole.keymap=us nouveau.modeset=0 rd.driver.blacklist=nouveau rd.driver.blacklist=i915 rd.driver.blacklist=drm video=vesa:off video.allow_duplicates=1 LANG=en_US.UTF-8

installed latest nvidia beta driver NVIDIA-Linux-x86_64-337.12.bin

My installed Manjaro freezes and trying to reinstal it from the latest live ISO also does not recognize the card Gforce GTX 750 Ti even they have the non free drivers at the ISO