Problems installing CUDA Toolkit 7 for GTX 980 Ti

Hello All!

I have a Ubuntu 14.04 running CUDA 7.0 with GTX 980 (4GB) and everything was fine until we decided we need more memory on the GTX 980 card.
So we bought GTX 980 Ti (6GB) and thought it was just to change cards.

But after the change we are running in to problems.
Command nvidia-smi reports back on all categories except “Name” where it gives msg “ERR!”.
When we try to run sample “deviceQuery” we get msg:
—>8—
…./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL
—>8—

We have tried to uninstall CUDA toolkit and reinstall it but same problem.

Any ideas what we have missed?

TTFN
//paus

Some extra system info:

smn1:/# ls -al /dev/nvi*
crw-rw-rw- 1 root root 195, 0 Jun 15 15:55 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Jun 15 15:55 /dev/nvidiactl

smn1:/# lsmod | grep -i nvi*
nvidia 8370774 0
drm 310796 2 nvidia

smn1:/# modinfo nvidia
filename: /lib/modules/3.16.7-ckt10snm-gpu-3.16.0/kernel/drivers/video/nvidia.ko
alias: char-major-195-*
version: 346.46
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00svsdbc04sc80i00*
alias: pci:v000010DEd00000AA3svsdbc0Bsc40i00*
alias: pci:v000010DEdsvsdbc03sc02i00
alias: pci:v000010DEdsvsdbc03sc00i00
depends: drm
vermagic: 3.16.7-ckt10snm-gpu-3.16.0 SMP mod_unload modversions
parm: NVreg_Mobile:int
—>8—

The 346.46 driver probably doesn’t recognize GTX 980 Ti.

Install this driver instead:

http://www.nvidia.com/download/driverResults.aspx/86390/en-us

Since you require a very new driver for support of this GPU, the recommended install method is to use the runfile installer that can be found at the above link. I would not try to use any repo/package manager methods to try and install a driver for this GPU.

This has the added wrinkle that if you previously used repo/package manager methods to install CUDA 7 (which is where the 346.46 driver came from) things will get more difficult. In that case, you’ll need to study the linux getting started guide instructions about clean-up when switching from one install method to the other.

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#handle-uninstallation

But based on the driver version number you currently have (346.46) I suspect you used the CUDA 7 runfile installer. In that case, just use the driver runfile installer from the first link above and you should be fine.

Thanks txbob :}

Worked like a charm!

TTFN
//paus