GeForce GTX 860m - any success stories?

I’ve promised my son a laptop suitable for Blender, Unreal … and it should all run on Arch Linux. I’ve been doing some research on laptops, and the most promising one has a GeForce GTX 860m. I’ve been doing quite some searches on “GTX 860m linux” etc, but all I seem to find is horror stories. This could be due to poster bias - people post when they don’t get things to work, but not when they get things to work. So I ask … does there exist any success stories, utilizing the GTX 860m under Linux?

I have it running in an Optimus configuration, and it works alright with the official driver. The only problem I have is a performance drop after suspending (then it’s slower than the integrated solution). Maybe I should create a thread for that here. It doesn’t work out of the box in Arch if it’s Optimus, I recommend the Bumblebee way for that.

I bought the laptop, it has arrived and I have successfully managed to get it up and running.

First attempt, no X configuration - X started, but no luck with OpenGL. Intel drivers used.

Second attempt, configuring X according to the instructions at https://wiki.archlinux.org/index.php/NVIDIA - X didn’t start, “No devices found”.

Third attempt, specifying BusID in the X configuration file. That really made a difference, the NVIDIA driver found the NVIDIA card, but no dice - black screen, it didn’t find the screen.

And then I read the notice “See instead NVIDIA Optimus if you have a laptop based on such technology” and installed bumblebee according to the instructions at https://wiki.archlinux.org/index.php/Bumblebee - that worked right out of the box, without any X configuration.

glxgears Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate. 304 frames in 5.0 seconds = 60.749 FPS 301 frames in 5.0 seconds = 60.082 FPS optirun glxgears
2713 frames in 5.0 seconds = 542.582 FPS
2734 frames in 5.0 seconds = 546.706 FPS

Then someone posted me this one: https://www.youtube.com/watch?v=O0r6Pr_mdio

If I had seen that before the purchase, I probably would have chosen a chipset from a different vendor :-)

Still not fully there yet - optirun works from my user account, but not from my sons user account - and that’s quite silly as I bought this laptop and graphics card primarly for him to be able to use blender.

Might have saved you some hassle

Also, have you added your son’s user to the bumblebee group?

Yes. I pinpointed the issue eventually. The difference between my account and my sons account was that I’m starting an xterm before I start the window manager (spectrwm), and then launched optirun from that xterm. Start optirun directly from the WM, or from an xterm that has been started from the WM, and the application dumps the core immediately.

I don’t have this issue with primusrun, but with primusrun there are other issues.

Indeed; I forgot to check back on this. There was still no reply in this thread when I ordered the laptop. I decided to order the laptop due to the shops return policy. I’m still not perfectly happy, but it seems to work - and I’ve invested too much (“invested” … maybe it should rather be considered as a sunken cost?) into getting it working, so I won’t return it.

I have a GTX 860m Optimus setup on Arch Linux using bumblebee. It seems to work, meaning I can run things with optirun/primusrun, but unfortunately the performance is horrible (and it makes the Nvidia card completely useless). Even the integrated Intel HD graphics card outperforms the Nvidia card in this setup (tested in Minecraft and glxgears).

If I run ‘optirun nvidia-settings -c :8’ and look under the PowerMizer tab I can see that the “Graphics Clock” seems to be stuck at 33 MHz at all times (even when running a game with optirun). I’ve tried changing the “Preferred Mode” setting to “Prefer Maximum Performance” but it’s still stuck at 33 MHz. A funny thing is that in the same tab it says that the minimum graphics clock speed is 135 MHz.

My nvidia driver version is 349.16-1 and the linux version is 3.19.3-3-ARCH.

The performance of my setup when running optirun/primusrun is bad from the second I boot. When you managed to get good performance (before suspending), did you run bumblebee or do you have something else?

So I’m not the only one. It works both with disabling the intel GPU and using Bumblebee, until I suspend. The driver notes say “* Resuming from suspend may not be reliable on GeForce GTX 9xx boards in some configurations.”, maybe my problem is related to this?
I’m also locked to 33Mhz, but sometimes when under load it goes a little above 250Mhz.

Lucky you (goes over 33 MHz). I started a new thread on this subject: https://devtalk.nvidia.com/default/topic/831369/linux/gtx860m-arch-linux-with-bumblebee-really-bad-performance/
Still no replies though. Really hoping for an Nvidia official response or just information on how to continuing with debugging.

I was able to fully harness the power of the 860m through the use of the official nvidia manual and the gentoo guide. This is my preferred solution because it yields the best performance with games. My huge asus laptop is too unwieldy to carry around without being plugged in anyhow. There is some screen-tearing, but that is described as “expected” by nvidia.

This is the route to victory:
https://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops
Also:
http://us.download.nvidia.com/XFree86/Linux-x86_64/343.36/README/randr14.html