General location of cusolverMg library

Hello,

I’ve written a sample code in the example of the cusolverMg document. The URL is here: https://docs.nvidia.com/cuda/cusolver/index.html#mgsyevd_examples. While I compile it, the compiler returns an error that the library ‘-lcusolverMg is not found’. So I’ve recognized that my /usr/local/cuda-10.2/lib64 folder doesn’t have libcusolverMg.so itself. I’ve tried to reinstall the toolkit but I still cannot found the library.

Furthermore, I’ve already tried the library in cuda-10.2/lib64/stubs folder and it doesn’t work also. Please, let me know where the library is?

My system has four K80C graphic cards and uses the cuda toolkit 10.2 version.

Through a packaging error, the installation of the libcusolverMg.so library was not done when using the runfile installer for CUDA 10.1.243 (CUDA 10.1U2) and CUDA 10.2. This error should be corrected in the next major CUDA release.

I believe it should be possible to get the library by using the package manager method to install CUDA. You don’t need to disrupt your driver install for this in an already functioning CUDA 10.2 setup. Just install the meta package

cuda-toolkit-10-2