Gentoo & Nvidia Optimus issues: MSI GE62 2QD Intel Core i7 5700HQ@2.7GHz+GTX960M

Hello.

My system:

  • Model: MSI GE62-2SQ Apache Pro
  • CPU: Intel Core i7 5700HQ @ 2.7GHz
  • iGPU: Intel HD Graphics 5600
  • dGPU: Nvidia GeForce GTX960M 2GB
  • LPC controller: HM87
  • Chipset: Intel 8 Series/C220 Series

I’m trying to make Gentoo work here: Im unable to make it stable and configure Nvidia Optimus.

  • I’m unable to extract EDID with get-edid from edid-read tools.

Kind regards.

PS: Posted on MSI Forums and Gentoo forums too.

Here’s the Xorg.0.log with latest xorg.conf, it looked the most promising one. The one with black screen maybe has good stuff, no idea.

https://paste.pound-python.org/show/STOxEGgrSGkm6jaOuSpK/

If you consider the others to be interesting to see, please request them and I’ll do the tests again. I did them but reported on IRC and forgot to save the URLs.

I followed the Gentoo wiki section about Optimus without success, then started to experiment with xorg.conf to have some hopes :/

I tried the following blog post that a user of Gentoo forums posted.

https://fitzcarraldoblog.wordpress.com/2015/07/01/switching-between-intel-and-nvidia-graphics-processors-on-a-laptop-with-nvidia-optimus-hardware-running-gentoo-linux/

I have a TOTAL MESS of xorg.conf files in /etc/X11, I’m in OCD mode trying everything. I should relax and think about this better, but I have nothing more to do really.

I tried the xorg.conf in the first blog post, the result is as promising as other I tried:

https://paste.pound-python.org/show/4dEiH2SstgUNAxxmlvnb/

The interesting part is this:

[  6517.086] (II) systemd-logind: got pause for 226:0
[  6517.086] (II) systemd-logind: got pause for 13:65
[  6517.086] (II) systemd-logind: got pause for 13:73
[  6517.086] (II) systemd-logind: got pause for 13:79
[  6517.086] (II) systemd-logind: got pause for 13:66
[  6517.086] (II) systemd-logind: got pause for 13:80
[  6517.086] (II) systemd-logind: got pause for 13:67
[  6517.086] (II) systemd-logind: got pause for 13:68
[  6517.086] (II) systemd-logind: got pause for 13:74
[  6517.086] (II) systemd-logind: got pause for 13:78
[  6574.050] (II) systemd-logind: got resume for 226:0
[  6574.075] (II) NVIDIA(0): Setting mode "NULL"
[  6574.134] (II) systemd-logind: got resume for 13:65
[  6574.135] (II) systemd-logind: got resume for 13:73
[  6574.135] (II) systemd-logind: got resume for 13:79
[  6574.135] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  6574.135] (II) systemd-logind: got resume for 13:66
[  6574.135] (II) systemd-logind: got resume for 13:80
[  6574.135] (II) systemd-logind: got resume for 13:67
[  6574.135] (II) systemd-logind: got resume for 13:68
[  6574.135] (II) systemd-logind: got resume for 13:74
[  6574.135] (II) systemd-logind: got resume for 13:78
[  6577.421] (II) systemd-logind: got pause for 226:0
[  6577.421] (II) systemd-logind: got pause for 13:65
[  6577.421] (II) systemd-logind: got pause for 13:73
[  6577.421] (II) systemd-logind: got pause for 13:79
[  6577.421] (II) systemd-logind: got pause for 13:66
[  6577.421] (II) systemd-logind: got pause for 13:80
[  6577.421] (II) systemd-logind: got pause for 13:67
[  6577.421] (II) systemd-logind: got pause for 13:68
[  6577.421] (II) systemd-logind: got pause for 13:74
[  6577.421] (II) systemd-logind: got pause for 13:78

Forget about “systemd-logind disappeared (stopped/restarted?)”. I killed it on purpose to test some stupid idea of myself ;)

Read this:
https://devtalk.nvidia.com/default/topic/957814/linux/prime-and-prime-synchronization/post/4964506/#4964506
and this:
https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Display_Managers

General hints:
run nvidia-bug-report.sh and attach output to post by editing it
intel/modeset entries have to be defined before nvidia ones in xorg.conf
Upgrade to xorg 1.19 to get prime sync.