Gentoo suddenly black screen on optimus K1000M

Hello everyone,

the other day upon restarting my ThinkPad W530 I noticed the screen would stay black with backlight leds on and the mic and micrphone leds off as well, this when booting using the Nvidia K1000M.

It also seems that if closing the lid the laptop won’t go to sleep as it should, and xrandar says can’t open display.

I really do not understand the reason since I didn’t do no particular changes to the system whatsoever.

After a complete kernel rebuild and playing around with some nvidia-drivers versions I ultimately gave up and booted back with the HD4000M.

I have literally spent the past 48 hours on this and I am at the border of craziness as I cannot find any errors that can give me a mare idea to what is causing the freeze/ hung from X, as I see the nvidia card being recognized from the xorg logs (though I am quite sure I could see the GPU edid in there, which I can’t now).

The setup has been done according to https://wiki.gentoo.org/wiki/NVIDIA/Optimus and has always worked before.

Kernel I am using is gentoo-sources-4.14.65 with nvidia-drivers-396.54 (though whichever drivers I tried from the portage made no difference).

Full kernel config can be found here https://paste.pound-python.org/show/FkgG5eW0TtivwPjXzXmZ

Xorg.cong I have been using so far can be seen here: https://paste.pound-python.org/show/7l3r6CrFNr7wfYiCsXBw/

Dmesg can be seen here: https://paste.pound-python.org/show/vdClAm4kcML1i6EIKNuK/

Full Xorg.0.log can be seen here: https://paste.pound-python.org/show/CVM23J8NiiZa4vgyf0Ok/

Kernel messages can be seen here (around midnight would be the timestamp): https://paste.pound-python.org/show/vNNInvcWszlDC0mRkxlV/

kern.log.0 can be seen here (around midnight would be the timestamp): https://paste.pound-python.org/show/N5sQYdGBB78HWHHahS0E/

I know I am asking you to review way too much stuff, and I am really sorry for that, but just I am at the verge of pulling down my system, and this is not something that I normally do or enjoy doing either, and yes the Nvidia GPU does work 100%.

The Gentoo community suggested this might very well be a bug since the nividia driver for the Optimus cards on Linux is a bit troubled…

Any help will be much appreciated :)

There’s no Optimus involved here, you probably set video to discrete only in bios. But you’re setting way too many and contradictory kernel parameters and options in xorg.conf which even turn off monitor detection.
Please remove at least the parameters
thinkpad_acpi.fan_control=1 drm_kms_helper.edid_firmware=edid/1920x1080_ThinkPad_W530.bin nvidia-drm.modeset=1 nomodeset
and maybe also
nox2apic
if that isn’t there for a specific problem
Then remove your xorg.conf, reboot and run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

I managed to get X to work again with the K1000M by compiling a fresh LTS kernel 4.14.68-gentoo-sources and =x11-drivers/nvidia-drivers-390.87 kms .

It has really been a struggle I have to admit. Thanks