Getting Started with Jetson Orin Nano

I want to get started with Jetson Orin Nano but I am facing a lot of difficulties.
Most of the tutorials out there are for Jetson Nano which is supported by JetPack 4.x. Jetson Orin Nano, however, is supported by JetPack 5.x.

Dusty said that " Hi @diegogarzon, that container is for JetPack 4.x and the course for the original Jetson Nano. You could copy the notebooks out of it and run them in the l4t-ml container instead (which is available for JetPack 5 and is pretty close to the DLI container - I think you may need to install jetcam ). The [Hello AI World ] tutorial is also on JetPack 5."

For instance, when I try to install the jetcam in the container, upon installing it, I still get “ModuleNotFoundError: No module named ‘jetcam’” error. This is even after installing jetcam. This is just one of the many problems I have faced during getting started with Jetson Orin.

For a start, how should I resolve this jetcam error?
Moreover, generally speaking, how would you suggest I get started with Jetson Orin Nano? Obviously there are compatibility issues between jetpack 4.x and 5.x but I believe they are somehow, some way resolvable.

Thanks in advance and cheers!

Hi @mchegini, are these the steps you ran to install jetcam inside the container?

Can you do pip3 show jetcam in the container? python3 -c 'import jetcam' ?

That package isn’t updated, so YMMV. One reason I recommended proceeding with jetson-inference if you were just getting started on Orin, is that it has been - I’ve also updated GitHub - dusty-nv/jetson-containers: Machine Learning Containers for NVIDIA Jetson and JetPack-L4T

I’m not sure if you have a specific direction you’re pursuing or interested in, but happy to help. These are also tutorials on JetPack 5: Home - Jetson Generative AI Playground

1 Like

First and foremost, I really do appreciate your response.

So this is the command that I am using the get the docker container up and running:
sudo docker run --runtime nvidia -it --rm --device /dev/video0 with volume and network mapping which I did not include in the command.
In the container terminal, I follow the guide on jetcam part of NVIDIA-AI-IOT repository. After running sudo python3 install, I open the Jupyter Lab and attempt to run the notebook that is provided in the jetcam folder which is named: “usb_camera.ipynb”.

The error that I get is:
ModuleNotFoundError: No module named ‘jetcam’

pip3 show jetcam gives: Package(s) not found: jetcam (I have run this both in the jupyterlab and container’s command line. So, despite having installed the the jetcam and having restarted the kernel of Jupyter multiple times, I still have faced that error.

I wanted to start working on your repository (the one that you introduced in your YouTube playlist but have gotten stuck for couple of days now :D)

I am now working on the playground to see if I am able to make something work. Nonetheless, I reckon your repository is a lot better for someone who is as amateur as me. Would you possibly have access to Orin to see if I am missing a small trick to get the jetcam working? Cause without Jetcam, the whole tutorial is kind of moot since I cannot use it for inference with my Logitech 270.

Thanks in advance!

OK, so I just tried this and found that jetcam was getting installed to /usr/lib/python3.8/site-packages/ (which wasn’t in the PYTHONPATH)

Instead, I built/installed the jetcam wheel and was able to import it then. These are the steps I ran in container:

cd /opt
git clone
cd jetcam
python3 bdist_wheel
pip3 install dist/jetcam*.whl
cd /
pip3 show jetcam
python3 -m 'import jetcam'

That said, it not being updated in 4+ years I don’t know if the camera acquisition in it still works or not (although the nvarguscamerasrc GStreamer element that it uses, is still providing in JetPack) That DLI tutorial is supported on the original Nano and JetPack 4.

1 Like

Thank you dusty. This was really helpful, and resolved the issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.