Gnome terminal problems ctrl-c and exit

After installing the stable nvidia driver for Quadra 4000 (opensuse 64-bit: NVIDIA-Linux-x86_64-331.20.run), I had some strange behavior in my gnome terminals. These problems disappear after downgrading to NVIDIA-Linux-x86_64-310.19.run.

  1. When running a command-line application, I can no longer use ctrl-C to terminate.

I can use ctrl-Z, then kill the process. But ctrl-C gets swallowed up. Even if I am just at the command prompt, the ctrl-C is not recognized. I checked to see if the keyboard shortcuts for gnome terminal had been changed, but no they had not. Copy is still the normal ctrl-shift-C.

  1. When I type “exit” from the command line, I lose my prompt but the gnome terminal does not close.

The only way I have to close the window is to use File->Close Window, or press the “X”. Again, I checked the gnome terminal settings. One setting controls what to do when the shell exits, and one of the possible settings is “hold”, keep the window open. But my setting was to close the window. I set it to “hold”, and then back again. No help. I can’t get shell exit to close the terminal window.

Keep in mind, by simply downgrading to an old version of the driver, these problems disappeared. I’m back to normal again.

I would like to upgrade my driver, but I won’t do it until I can use my gnome terminals in the normal way. Any help is very much appreciated!!

I am having the same issue you described with closing the terminal using 331.20 on 3.10.17-gentoo 64Bit with a GTX 760. ctrl-C works for me.
I’ve also had this problem with 319.60. Currently I am using 325.15 which works fine.

Unfortunately the only workaround I found is using an older version.

I tracked this down to SIGINT being masked somehow with 331.20. Downgrading to 325.15 fixed the issue for me. There’s more information in this redhat bug https://bugzilla.redhat.com/show_bug.cgi?id=1028272

Same problem as https://devtalk.nvidia.com/default/topic/633706/linux/recent-drivers-cause-applications-to-hang-not-start-at-all-or-compilation-failures/, see https://devtalk.nvidia.com/default/topic/633706/linux/recent-drivers-cause-applications-to-hang-not-start-at-all-or-compilation-failures/post/4023516/#4023516 and the bug reports linked in this thread.

I hope that this is fixed soon :(

Hi all, Please attach nvidia bug report. Filed bug 1414070 to track this issue.

I also have the same issue.
Once i installed 319 driver, ctrl c stopped to work.
I run stty intr ^G, switch to different key, it did not helped. CTR G was not work as well.
Switching to version 304 helped.
I’m in 64 bit ubuntu 13.10 with Cinnamon. NVIDIA Corporation GF106GL Quadro 2000
Funny, but i don’t remember seeing this bug under 32 bit ubuntu, with same graphics card.

Me too (Fedora 18, driver 331.2). I can’t reproduce it consistently. Sometimes it’s really common and others it can work 99 times out of 100. It seems to be more common in my apps with more code. http://stackoverflow.com/questions/20049025/cant-ctrl-c-my-sdl-apps-anymore

Hi all, We are not able to reproduce this issue in house. Please attach nvidia bug report.

The specific differences I have noticed on my system between 325.15 and 331.20, is that with 331.20 I do get defunct processes appearing over time. And I have a similar problem as OP posted with the Xfce4 terminal. Sometimes the terminal will close correctly, other times it hangs. It is the same whether I type “exit” or press ctrl-d.

I am also using xscreensaver, and when I open the Xfce4 settings for screensaver, the window itself hangs when I attempt to close it.

Edit: I just want to specify that if I downgrade to the 325.15 driver, then all these problems disappear. Upgrading to 331.20 and the problems reappear.
nvidia-bug-report.log.gz (205 KB)

Reading through, I get the impression that the problem is intermittent and irregular with you people. Not so for me, Ctrl+c works but exit fails each time. I lose my prompt, the cursor simply shifts to a new line and does nothing. Repeatedly typing exit also doesn’t do anything (heard that it works for some people). Ctrl+d, Ctrl+z work but to actually exit the terminal (close it) I have to click the close (X) button.

This happened only after I recently upgraded my nvidia graphics driver (Arch linux, full system upgrade). I use Xfce. List of nvidia software installed (running pacman -Qs nvidia) -

local/lib32-nvidia-libgl 331.20-1
NVIDIA drivers libraries symlinks (32-bit)
local/lib32-nvidia-utils 331.20-1
NVIDIA drivers utilities (32-bit)
local/libcl 1.1-3
OpenCL library and ICD loader from NVIDIA
local/libvdpau 0.7-1
Nvidia VDPAU library
local/nvidia 331.20-1
NVIDIA drivers for linux
local/nvidia-libgl 331.20-1
NVIDIA drivers libraries symlinks
local/nvidia-utils 331.20-1
NVIDIA drivers utilities

adityarajbhatt, Please provide bug report

Same error here, I can also confirm that a downgrade to 325.21 fixes the problem.

Kernel 3.12 with funtoo current

nvidia-bug-report.log.gz (86.3 KB)

This is bit tricky issue to repro. I am able to repro this issue with openSUSE 13.1 “Bottle” x86_64 + GK107 [GeForce GTX 650] [10de:0fc6] + 331.20 (R331_00) + xterm

  • Login to xfce desktop via gdm as test user
  • start > Run Program > xterm . Open one more xterm by typing command xterm from already opened xterm.
  • Now you have two running xterm windows. Now try to close parent xterm with mouse click. It will not close.
  • Now try close child xterm with Ctrl+C in parent xterm, it will not close.

This issue is fixed with our latest driver will be available soon.

Thank you very much for the feedback.

Hi, could you precise since which version of driver is this issue fixed?
Thanks in advance!

this is the same issue as discussed in https://devtalk.nvidia.com/default/topic/659230/331-20-on-x86_64-breaks-signal-processing-/

it is fixed with driver 331.38.

Thanks a lot. I confirm that my problems are fixed in this version of driver (Gentoo, XFCE4)

Thanks, this is now fixed in the 331.38 driver.