Gnome/xorg problems with dual-monitor 144hz performing as 60hz

Hi everyone, first of all i’m sorry if there’s a post which i haven’t seen yet with this same problem, but i at least did my research for at least 4 hours without finding any solution for my problem. Also, i’m kind of new user to linux as I installed it just yesterday. As said in the title, when using double-monitor (one 144hz, and the 2nd -which is my laptop screen- is 60hz), the 144hz performs at 60hz with only the cursor moving at 144hz. This only happens on Xorg, in wayland it’s fixed but i don’t like using it because of worse driver support. Already tried setting __GL_SYNC_DISPLAY_DEVICE=HDMI-0 and setting manually refresh rate on Nvidia X Server, as well as creating a 20-nvidia.conf with launch parameters so it makes the change at every startup, still nothing works.
Currently, the only thing that has worked so far for me was installing KDE Plasma desktop and using it but i don’t like how it looks so here i am. I’m suspecting it may be the iGPU that is making this kind of bug? because every solution i’ve come across so far was putting that line on the environment path.
My Laptop specs are:

HP Omen 15
RTX 2060 (Mobile)
I5-10300H

Thanks in advance!

Also, forgot to mention i already tried as well :
CLUTTER_VBLANK=none
CLUTTER_DEFAULT_FPS=144
and didn’t work

Forgot to mention, as i’m new to Linux couldn’t post any log or whatever, so if you need me to do so just ask and i’ll search how to do so!

The CLUTTER_ variables have been removed from gnome long time ago. The _GL_SYNC_DISPLAY_DEVICE might work but only under some circumstances. Overall, this isn’t reliably working with gnome on xorg
https://gitlab.gnome.org/GNOME/mutter/-/issues/1470

I did already read that entire thread and yeah, nothing worked for me:(
So as it doesn’t have a fix yet i’ll just have to use wayland instead?

Yes, since gnome/mutter on Xorg is in maintenance mode only, this won’t change.

I ended up switching to kde, and on kubuntu worked perfectly, just had to open nvidia-setting every time I logged in but adding to /etc/environment the __GL_SYNC_DISPLAY_DEVICE=HDMI-0 variable made it work automatically.
The problem now is that i’m running Manjaro KDE and that variable on /etc/environment doesn’t seem to work, as i have to open nvidia-setting every time i log in.
I already exported it on .bash_profile (export __GL_SYNC_DISPLAY_DEVICE=HDMI-0
)and doesn’t work either.
Any suggestions? or in Manjaro KDE /etc/environment doesn’t work as on kubuntu?

Update:
I made a login script with “nvidia-settings --load-config-only” so it works now as it runs nvidia-settings at startup.
Problem fixed.

/etc/environment is a mess in linux, every distro handles it differently, often badly or not documented at all. Try using the variable directly or with “export”. Fine you found a work-around that works for you, though.