How to force 120Hz / 144Hz

I’m having a lot of troubles with this, i can set a 144 refresh rate in nvidia-settings, and save the configuration into /etc/X11/xorg.conf but when i restart the resolution and framerate goes “auto (1920x1080x60)” again.

Here you can see more information about my problem: https://www.gamingonlinux.com/forum/topic/1654?page=1

Set the refresh rate from “Display” utility of OS like Display in Unity and gnome-display-property in GNOme . Save changes there and I think that settings will be persistent also after X start.

Ehm, perhaps silly question, do you have dual link DVI?

I have same problem unsolved and I have dual link DVI, suggestions?

For my Acer i had to create some specials modelines in me xorg.conf for the reals refresh rates.

ModeLine “1920x1080_60” 148.50 1920 2008 2052 2200 1080 1084 1089 1125 -hsync +vsync # 60 Hz
ModeLine “1920x1080_100” 236.54 1920 1968 2000 2080 1080 1083 1088 1138 +hsync +vsync # 100 Hz
ModeLine “1920x1080_110” 261.39 1920 1968 2000 2080 1080 1083 1088 1143 +hsync +vsync # 110 Hz
ModeLine “1020x1080_120” 286.75 1920 1968 2000 2080 1080 1083 1088 1149 +hsync +vsync # 120 Hz

Hope helping.

I have a LC32JG Samsung, it says 144hz in the screen options but i can’t unstuck my computer from 60hz, going in the nvidia panel i found that i can try out custom values, there i forced it to 144hz, endless loop of connection to the DP, screen can’t read? 1060gtx. So wtf is the screen subdividing the shit out to 144hz or something ? Even so it should be fine with 144hz input :/…

I had the same issue until I figured out the trick… Set the resolution and refresh rate in Nvidia Settings. Save that then open your system’s Display Settings (In Mint, which I’m using it’s the one in System Settings / Hardware / Display. Hit the “Apply” button.

Now the refresh rate sticks between reboots…