Monitor Refresh Rate Ubuntu MATE 22

Had my Ubuntu MATE system (22.04) was using Nvidia 510 drivers. At random looking at nvidia-smi I noticed the power draw elevated at idle. About 75 Watts. Did some research and it was a known issue and was fixed in the 515 driver.

Updated to 515, cool power draw normalized. BUT…my monitor no longer could be set to 144hz. If I tried, it would go standby. Wouldn’t revive until reboot. Settings would not stick.

Tried via the additional drivers gui and straight from NVIDIA. Figured I would need to go to most recent release for the newer drivers, gave that a try…nada.

Tried addressing settings directly in xorg.conf, tricks like set in nvidia settings and then the ubuntu display app and vice versa…nothing. Straight to standby.

Turned off and on the monitor a few times. Unplugged it, everything.

So what do I know, it works on Windows 10 at 144hz, it works on 22.04 and 22.10 with nvidia 510 drivers and nothing else. But the excess power draw…

Anyone have an idea on what to do next. All symptoms point to the drivers.

before I forget the system:

Gigabyte 3080 TI Vision
Gigabyte M32U (4k 144hz)
Some LG 4k 60hz monitor

CABLES CABLES CABLES - all HDMI 2.1
Original Cable that came with monitor
Monoprice cable (successfully works for 4k 144hz driver 510)
Club 3D

Window Manager: Marco: XPresent

Ubuntu Mate 22.04 and 22.10

Proprietary NVIDIA drivers 510,515,520 and respective open kernel drivers if they exist.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

1 Like

Driver 510 - Power Draw

nvidia-bug-report -510.log.gz (264.2 KB)

Driver 520 - Cannot set refresh rate to 144hz or anything above 60
nvidia-bug-report -510.log.gz (264.2 KB)

Did you set the refreh rate to 144Hz before taking the logs?

1 Like

I thought I had for 510. For 520 no, I’m unable to, there in lies my issue for 520.

I suppose with 520 reportedly fixing the power draw issue I guess to conclude and make my ask for help more concise is to find a way to apply 144hz and not have the monitor go into standby. This happens when writing in 144 in xorg.conf (I did not do prior to providing this log)

Sincere apologies for the confusion.

Hi @generix, sorry to be a bother on a trivial matter. Can you point me in the right direction. Doesn’t need to be the full answer but a thread or error to look into.

Thank you for your time. Much appreciated.

What kind of DE are you using?

Thank you generix. I am using:

Mate 1.26.0 per neofetch.

Kindest,

John

I don’t understand why you’re “writing in 144 in xorg.conf”. This shouldn’t be done this way. What happens when you set the refresh rate in Mate’s display settings?
https://www.technipages.com/linux-mint-configure-output-resolution
Please create a new nvidia-bug-report.log afterwards.

In a fresh install of Ubuntu Mate 22.10 and Driver 520 the option for 144hz disappears. That was a ham fisted way of trying to remediate.

nvidia-bug-report.log.gz (295.0 KB)

Ok, now I understand your problem. Please create (with 520 installed) /etc/X11/xorg.conf.d/nvidia-modedebug.conf

Section "OutputClass"
    Identifier "nvidia-modedebug"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "ModeDebug" "true"
EndSection

after reboot, please create a new nvidia-bug-report.log

Sorry for the information overload. This should do it.

nvidia-bug-report.log.gz (402.7 KB)

[     9.787] (WW) NVIDIA(GPU-0):     3840 x 2160 @ 144 Hz
...
[     9.787] (WW) NVIDIA(GPU-0):     Unable to determine HDMI 2.1 Fixed Rate Link
[     9.787] (WW) NVIDIA(GPU-0):     configuration.
[     9.787] (WW) NVIDIA(GPU-0):     Mode is rejected: Unable to construct hardware-specific
[     9.787] (WW) NVIDIA(GPU-0):     mode timings.
[     9.787] (WW) NVIDIA(GPU-0):     GPU extended capability check failed.

Usually, this points to the mode requiring DSC which isn’t supported by the linux driver. Since this worked with the 510 driver, I suspect nvidia lowered the threshold for when DSC is needed.
Please delete /etc/X11/xorg.conf.d/nvidia-modedebug.conf
and instead create /etc/X11/xorg.conf.d/nvidia-modeval.conf

Section "OutputClass"
    Identifier "nvidia-modedebug"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "ModeValidation" "NoExtendedGpuCapabilitiesCheck"
EndSection

though I don’t think this will help. The mode will show up again but using it will most likely just give you a black screen.

Not so much luck - mode did not return.

I will keep tabs on the below tread to see if there is a workaround for the idle power usage for driver 510 if we have exhausted all possible fixes for Driver 520.

AND THANK YOU!