Many refresh rate missing using NVIDIA 545 drivers on Alienware aw3423dwf


I have a monitor that supports up to 3440x1440@165, but the maximum shown by wlr-randr is 3440x1440@100. I’m running hyprland Arch Linux which is my main system.

I tried booting with a live image of arcolinux-hyprland-v24 and garuda-hyprland but I have the same problem, both using proprietary drivers.

I did the same in ubuntu sway 23.10, garuda-hyprland and kde-neon, these times using nouveau drivers, and the correct refresh rate was shown.

Finally, I tried arcolinux-plasma-v24 using proprietary drivers. This booted an X11 session (all the previous were wayland sessions). I run xrandr and the monitor is again capped at 100hz.

So, the issue seems to be with proprietary drivers and uncorrelated to the graphic session.
I’m attaching the logs for the main system.

  • Monitor: Alienware 34 - AW3423DWF
  • Gpu: GTX 1070

nvidia-bug-report.log.gz (1.4 MB)

Please enable mode debugging by switching to X11 and creating

Section "OutputClass"
    Identifier "nvidia-modedebug"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "ModeDebug" "true"

Afterwards, please create a new nvidia-bug-report.log.

Ok, I did what you said in the live image since I don’t have X11 packages on my main system.
nvidia-bug-report.log.gz (1009.7 KB)

That’s the same log from a wayland session you attached earlier.

I’m sorry, I edited the comment with the correct one
Let me know if that’s anything else I can try.
I also tried in windows 11 and I can confirm it works @165hz

[   394.136] (WW) NVIDIA(GPU-0):   Validating Mode "3440x1440_165":
[   394.136] (WW) NVIDIA(GPU-0):     Mode Source: EDID
[   394.136] (WW) NVIDIA(GPU-0):     3440 x 1440 @ 165 Hz
[   394.136] (WW) NVIDIA(GPU-0):       Pixel Clock      : 1019.28 MHz
[   394.136] (WW) NVIDIA(GPU-0):       HRes, HSyncStart : 3440, 3488
[   394.136] (WW) NVIDIA(GPU-0):       HSyncEnd, HTotal : 3520, 3600
[   394.136] (WW) NVIDIA(GPU-0):       VRes, VSyncStart : 1440, 1443
[   394.136] (WW) NVIDIA(GPU-0):       VSyncEnd, VTotal : 1453, 1717
[   394.136] (WW) NVIDIA(GPU-0):       Sync Polarity    : +H -V 
[   394.136] (WW) NVIDIA(GPU-0):     ViewPort 3440x1440 exceeds hardware capabilities.
[   394.136] (WW) NVIDIA(GPU-0):     Mode is rejected: GPU extended capability check failed.
[   394.136] (WW) NVIDIA(GPU-0):     GPU extended capability check failed.
[   394.136] (WW) NVIDIA(GPU-0):     Mode "3440x1440_165" is invalid.

Driver bug. Please recheck with the latest 550.54.14 driver, if that also doesn’t work, mail the report to linux-bugs[at], maybe you’ll get some attention.

Just installed driver v550, it works now! Thank you

Duplicate / related: Headless fullscreen RANDR usage with ConnectedMonitor has restricted resolution on even-numbered ports

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.