No 144Hz option for Asus MG279Q Monitor

Driver doesn’t seam to see the 144Hz refresh option of the monitor. Max I can use is 120Hz.

EDIT:
Using Arch and latest driver available

How is the monitor connected to the GPU? I don’t think HDMI has enough bandwidth to support 144 Hz at 2560x1440. If you’re using DisplayPort and it’s still not available, can you please run nvidia-bug-report.sh and attach the resulting nvidia-bug-report.log.gz file to this thread?

Sorry for the late reply, but yes, it is connected via DP.

Here is nvidia-bug-report
nvidia-bug-report.log.gz (223 KB)

Just a heads up saying the the problem is still present in 358.16

Please add ‘-logverbose 6’ to your X-server’s command line options, restart X (or reboot), re-run nvidia-bug-report.sh and attach the result to this thread.

Did you run nvidia-bug-report.sh in a TTY or su -? Coz it can’t even run xrandr:

xrandr --verbose:

No protocol specified
Can’t open display :0

Would be great if you can attached the EDID in binary format of the ASUS monitor, which can be acquired in nvidia-settings. We can then decode it easily to see anything wrong in it.

OK, my bad. Here’s the nvidia-bug-report with everything in it.
nvidia-bug-report.log.gz (251 KB)

Once again, the verbosity level of your log doesn’t provide adequate information to troubleshoot your issue. Please follow the instructions in my earlier post.

I’m sorry, totally missed your last post. Here’s the correct log file now.
nvidia-bug-report.log.gz (231 KB)

[   296.274] (WW) NVIDIA(GPU-0):   Validating Mode "2560x1440_144":
[   296.274] (WW) NVIDIA(GPU-0):     Mode Source: EDID
[   296.274] (WW) NVIDIA(GPU-0):     2560 x 1440 @ 144 Hz
[   296.274] (WW) NVIDIA(GPU-0):       Pixel Clock      : 586.00 MHz
[   296.274] (WW) NVIDIA(GPU-0):       HRes, HSyncStart : 2560, 2568
[   296.274] (WW) NVIDIA(GPU-0):       HSyncEnd, HTotal : 2600, 2640
[   296.274] (WW) NVIDIA(GPU-0):       VRes, VSyncStart : 1440, 1465
[   296.274] (WW) NVIDIA(GPU-0):       VSyncEnd, VTotal : 1473, 1543
[   296.274] (WW) NVIDIA(GPU-0):       Sync Polarity    : +H +V 
[   296.274] (WW) NVIDIA(GPU-0):     ViewPort 2560x1440 exceeds hardware capabilities.
[   296.274] (WW) NVIDIA(GPU-0):     Mode is rejected: GPU extended capability check failed.
[   296.274] (WW) NVIDIA(GPU-0):     Mode "2560x1440_144" is invalid.

Apparently you need this according to the README:

Option    "ModeValidation" "NoExtendedGpuCapabilitiesCheck"

http://us.download.nvidia.com/XFree86/Linux-x86_64/358.16/README/xconfigoptions.html

I don’t know what’s “GPU extended capability” though. So use with caution :P

Thanks @tomty89 for the help. Just tried the above option and the result is, it enables the monitor (the monitor doesn’t work while in text mode for some reason [don’t know if it’s normal while connected via DP]) and at the correct frequency (144Hz), but no image is displayed. Now, please don’t tell me that a GTX 770 4GB can’t handle a DP 1440p monitor at 144Hz and a HDMI 1050p at 60Hz. This isn’t normal…

As far as I know there is an internal PixelClock Limit of 400 Mhz in the driver.
2560x1440 @ 144 Hz requires 586 Mhz. That’s why someone wrote a patcher to uncap the driver.

https://github.com/CFSworks/nvlinpatch

Unfortunately it doesn’t seem to work with the newer driver even when I edit the Python script.
I have a 2560x1440 monitor which I can overclock to 120 Hz with adjusted timings, but it also exceeds the PixelClock limit. On Windows the driver needs to be patched for this, too. At the moment I’m running it at 96 Hz via custom EDID, which is a Pixel Clock of just below 400 Mhz.

There is the “NoMaxPClkCheck” ModeValidation Option, but I don’t think that uncaps the driver. Might be worth a try for you. Doesn’t work for me, when I try to force an EDID with 2560x1440 @ 120 Hz as default mode. Maybe it needs to be used together with “NoExtendedGpuCapabilitiesCheck” which sounds like it removes the limit from the driver.

Well, I have mine working at 2560x1440 at 120Hz so that can’t be the same problem…

I don’t think he needs another ModeValidation option if he is sure that mode is accepted and being used.

So do you mean you never saw any tty with DP? What if you connect the card ONLY with the DP monitor/connection?

Maybe you can try start X with -logverbose 6 again with:

Option "MetaModes" "2560x1440_120"

in addition to NoExtendedGpuCapabilitiesCheck; and then try a switch cycle with xrandr:

xrandr --output DP-1 --mode 2560x1440 --rate 144; sleep 5; sudo nvidia-bug-report.sh; xrandr --output DP-1 --mode 2560x1440 --rate 120

From the point I start the computer until X starts, I never see anything on the monitor. And it’s actually on standby, so, not receiving any signal on the DP port. Only after the driver loads and X starts I have image on the monitor.
I’ll try later today to see if anything changes if I change the DP connection on the card and remove the other monitor.

The mode is in fact accepted as the screen turns on as if receiving signal (and using the correct refresh rate, confirmed using the monitor OSD), but no image appears. I’ll try the xrandr “trick” later today…

Ok, monitor connected only via DP, same problem. (card only has one DP port)

You mean with any monitor and any type of connection or only the specific monitor and/or DP connection?
If it’s the former have you tried the other DVI port (the DVI-I one)?

No, it’s only with this monitor/DP connection. I don’t have any other DP Monitor and connected via DVI works fine.

Same problem with 361.18

Just a heads up saying that still doesn’t work with 364.16