KDE Wayland cannot be started on 545 when refresh rate is above 60hz RTX 4080

Currently a bug which I believe is similar to another user report which was fixed has reared its head again

I’m currently running Arch on kernel 6.6.9 My main monitor is 4k 120hz. G-sync compatible. My secondary is 1080p 60hz. Non G-sync

If the primary monitor is set to 120hz when starting wayland, video card will stop all video output and the monitors will simply be black and scan for a signal. The issue is resolved by logging into X-org and changing the refresh rate back down to 60hz. Wayland boots normally after the change. The refresh rate can be changed to 120hz once the wayland session is started. However, logging out of it, changing to tty or anything that kicks you out of the wayland session will recreate the bug until refresh rate is lowered back to 60hz. The problem does not exist on X-org.

Both monitors are connected via HDMI.

I think this issue is more than just cannot start the session, at least according to my tests with my 3090 on both X11 and wayland with 545 - 120hz does the same exact thing described above, which I reported here:

Both of my monitors however are 165Hz and they work just fine under both X11 and wayland, I do suspect this issue is exclusively with 120hz which in your case it seems to break the entire session.

Hm… So the issue is linked to 120hz. My monitor can output 144hz if I switch to Display Port. I just don’t have a cable on hand.

In your experience, going above 120hz fixes the issue?

Do you know if an internal bug report has been filed from your original reporting of the issue?

Bumping this again.

After the new driver update the problem persists. RTX 4080. 550. Arch. Wayland. If there is a dual monitor setup and one of the monitors is 4k 120hz. Both monitors will black screen. The issue exists in the new drivers.

Just to confirm, 120hz still seems borked on 550, I get no output on wayland session, but for me it works on xorg, it specifically happens with 120hz(everything else seems to be working - 60hz/144hz/165hz at least in my case)

Reporting this is still an issue for me on 550.54.14. Have to set monitors to 60hz before rebooting/logging out then put 144hz back on when I log in again. If I log out with 144hz enabled on any screens then the bug happens. Only thing I can do to fix it is log in via x11 (which I always have 60hz everything) and remove saved config files.

nvidia-bug-report.log.gz (1.0 MB)

We have a bug 4566516 filed internally for tracking purpose.
Shall keep updated on the bug status.

+2 As I saw at least one other report besides mine:

Mine: [Regression] (550.54.14) Native HDMI 2.1 signals i.e above 4k60Hz won't work on 8 bit output (hdmi_deepcolor=0)

Other one: [SOLVED] 550.54 & 550.67 break 120hz on LG C2 TV Monitors; 545.29 is last working version - #10 by saschaheid