Monitor (refresh frequency) overclocking in Linux is not available

My IPS monitor supports a 75Hz refresh rate under Windows and I’ve no idea how to enable it under Linux.

In Linux nvidia-settings offers refresh rates only from interlaced 50Hz to 60Hz.

In Windows I just run NVIDIA control panel, click “Add a custom refresh rate”, specify 75Hz, hit apply and everything just works. Not so much in Linux.

I tried entering my monitor HorizSync and VertRefresh values into nvidia.conf but that didn’t help.

Use

Option "ModeValidation" "AllowNonEdidModes"

to unlock.

Well, I’ve done everything pretty much manually and here’s how it goes:

$ cat nvidia.conf
Section "Device"
        Identifier      "Videocard0"
        BusID           "PCI:1:0:0"
        Driver          "nvidia"
        VendorName      "NVIDIA"
        BoardName       "NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)"
        Option          "Coolbits" "28"
        Option          "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
        Option          "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x3; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"
        Option          "UseNvKmsCompositionPipeline" "Off"
        Option          "TripleBuffer" "On"
# Doesn't work or help anymore
#       Option          "RegistryDwords" "RMUseSwI2c=0x01; RMI2cSpeed=100"
        Option          "UseEDIDFreqs" "Off"
EndSection

Section "Screen"
    Option          "ModeValidation" "AllowNonEdidModes,NoEdidMaxPClkCheck,NoMaxPClkCheck"
    Monitor        "Monitor"
    Identifier     "Screen"
    Device         "Device"
EndSection

Section "Monitor"
    Identifier     "Monitor"
    HorizSync       30-83
    VertRefresh     56-75
EndSection

And then this script.